3d background of Dynamo in Revit is not visible

Dear all,
I am new to dynamo and was trying dynamo with Revit, I have rectified 2017, dynamo 0.9.1 comes along with Revit, when I work in sandbox dynamo works fine but with dynamo in Revit I cannot see 3d background. I reinstalled the whole thing and even installed dynamo 1.2 but no use can someone help me. Please.

Hello, there are maybe some preliminary answers to be found through the search field:



Hi Sunil,

I have faced the same issue with my AMD graphics processor.
The issue was resolved when I changed the default graphics for dynamo from High performance to Power saving graphics. The background preview is visible and workable.

Kindly refer to https://github.com/DynamoDS/Dynamo/issues/5818#issuecomment-261055495

2 Likes

This was the same problem I had recently! With mine, the AMD driver uninstalled itself and defaulted to Intel HD graphics.

1 Like

I have Dell Inspiron r15, with i5-2410m 4gb ram

Above are the configuration of laptop and Nvidia setting, in sandbox I can see 3d background while in Revit I cannot see that.
Please tell me step by step as I am not tech savvy.
Appreciate your help

Hi Sunil,

Kindly change the ‘preferred graphics processor’ to Intel/Default Graphics and try starting Revit. I suggest to do this as it resolved the issue in my work laptop.

Revit doesn’t rely much upon the high-end graphic processor for Visuals compared to Rhinoceros which uses GPU acceleration for display.

Regards

1 Like

Thanks it worked

1 Like