New Dynamo user no preview


I am new Dynamo user, who just installed Revit 2019 and opened the Dynamo Sandbox from program files. I believe I do not need to download dynamo as it is part of Revit?

After openning the Dynamo for the first time, I tried to draw a simple circle, but nothing appears on my screen. What is wrong?

I do not see the grid as in typical tutorials.


  1. Right-click the desktop
  2. Choose “NVIDIA Control Panel”
  3. Click “Manage 3D settings” on the left
  4. Click the Program Settings tab
  5. Under Select a program to customize , click the drop-down menu
  6. Select Autodesk Composite or Autodesk Revit
  7. Select “High-performance NVIDIA processor” in the drop-down menu under Select the preferred graphics processor for this program .
  8. Click Apply (might need to scroll down to see this button)
  9. Close the NVIDIA Control Panel
  10. Re-test

Looks like you have to force the graphics to only use the gpu with your hardware setup.

How to do this will vary by GPU, but typically it’s started by right clicking the desktop and launching the graphics adaptor set up from there. This is a pretty good article on controlling those settings:


Did changing Nvidia settings help to solve the problem? I have the same in Revit2020 and tried updating Nvidia and changing the settings as Autodesk recommended, but still can’t solve it.

Can you start a new topic posting a screenshot of what you see?

sure, I’ve done that