Memory Error in Refinery

I am getting the following error when executing a large dynamo script in Refinery:

The error seems to be related to lack of RAM even though it was at 70% when the message appeared. The graph seems to keep running but Refinery and Dynamo get closed as soon as I click on OK.

These are the PC specs:
Workstation Dell Precision Tower 3620
CPU Intel Core i7-7700K CPU @ 4.20 GHz
GPU (dedicated) NVIDIA Quadro K620
GPU (integrated) Intel HD Graphics 630

Any advice on how to overcome this is much appreciated!

@Lilli_Smith FYI

1 Like

@julianz can you post the graph and relevant files? Dev team requested them as this error is rather infrequent and they have not been able to reproduce.

FYI: @Neal_Burnham

1 Like

Unfortunately, I can’t post the source files in here given that the forum is public, but I am happy to send them directly to whoever needs them. Would that be you and @Neal_Burnham?

Let me know and I will send the files through direct message,

Yes, thanks Julian,


1 Like

Great! Just sent you the files.

Also, a couple of updates:

1. I am running DynamoCoreRuntime2.5.1 and Refinery v0.62.2 with the following packages in use: LunchBox, DynamoText, MeshToolkit, Clockwork, and GenGHG_GeometrySYS_2 which is a custom node (also included in the files sent).

2. The script is still running (almost 20 hours after the error came up) now I am at 1,372 generations. I am hoping to be able to collect the results once it finishes.

2. I have made several tests with different versions of the script and it seems that the “Views Analysis” (shown in blue below) is what is causing the error. The red portion can run many more iterations without any error popping up, meaning that the bottleneck is likely related to an inefficient script that consumes lots of RAM (probably my bad!). Still, I am wondering whether this is true or not as RAM usage doesn’t go above 75%.

Hope this helps and thanks!

Any luck with this? :frowning: I recognize this may be complex to troubleshoot but I am happy to answer any questions right away. I have tried the optimization mode as well but Refinery keeps running forever if I select more than the standard number of generations/population size/seeds. In Randomize, I’m still getting the memory error after a large number of generations.

Rather than a magic solution from you, I’d like to know your thoughts on whether this is caused by a lack of resources problem or a bad code problem, and if you have insights on where should I focus my efforts to make it work.

I really appreciate the time that you put into this!

It seems that those performance improvements are really making a difference - the problem recently got solved after trying with the latest Dynamo 2.8.0 daily build, now I am finally reaching +1000 iterations without the memory error popping up.