Project Refinery - JavaScript error

Hello,
Refinery gives me this “JavaScript error occurred in the main process” that can’t be ignored, preventing me from the possibility of using the tool and run a certain graph that in Dynamo is running well.

The window used to pop up or when I open Refinery or when I click on the “New Study” button or when I click on the graph I want to run.
Lately, it is appearing right when I launch Refinery.
Error occur both in Revit versions 2019.2 and 2002.2.

JavaError

Any clue about how to understand the reason for this error and, possibly, figuring out a solution?

Thanks!

I understand the cause of the problem is a node from Data-Shape, GeomPreview.
@Mostafa_El_Ayoubi
Capture

The node itself is so wonderful and in dynamo works very well but unfortunately gives me this error in Refinery.

Unfortunately, the topic is not solved because, after updating refinery to the version 0.62.2, the same error appears again. I updated to this version because the remember data node was not working and I found a post on the forum saying that is an issue of the refinery version.

I already try to delete all the studies/graph from the document folder but with no improvement.

Any idea?

Likely a failure is a result of a code dependency conflict if some sort (though I am not sure which/what). However Refinery based graphs shouldn’t have a need for such a UI - you don’t get to pick stuff in the graphs via UI when using it as there is no interaction at all. Try doing a save as, using a remember node to record the selection, save the graph, and delete this node (and do the same for any other UI nodes). You can always add these back later.

FYI @Lilli_Smith

1 Like

Thank you Jacob, deleting all the UI and all the studies from the Document folder on my pc, now started to works again!

Only issue now is about the Data.Remember node that seems not to works.
I need to use it in a really classical way: bringing to Refinery the geometry extracted from some model lines in Revit.

Is this of the Data.Remember node a known issue?

Is the list of lines a flat 2 dimensional list? Has the data been remembered and just isn’t saving, or is it returning null? Can you post your graph for review?

Hi Giuseppe,

Are you using the latest beta of Refinery from our beta site? (ver 0.62.2)

Thanks,

Neal, for the Refinery Team

Yes, it is a 2 dimensional list. I used to run the script already with the data.remember node in the graph and, after saving, I exported it on refinery (“Generative design” > “Export for generative design”).

If you need the .dyn I can clean up part of the graph in order to send to you but I really think that the problem is just about this very beginning part. In fact, these lines are even not visible I refinery solutions’ preview

Hi Neal,
Yes, 0.62.2!
I am appreciating a lot the improvements and, since you’re for Refinery Team, I would like to share with you some other weird thing like the scrolling menu’ in the graphics result that doesn’t allow you to read all the parameter (see image below)

Hello,
The Data.Remember node really seems not to works for me. I created a really simple graph using the same element of before. Here the images:



input: the slider named “frequency”
output: Watch node named “Area”

In Refinery, the result gives me a table where all the value corresponding with the output are empty.
(by the other end, I know that the script ran anyway because I have multiple option for the input)

Try removing the convert units node and just do the math manually by division. As that node has a UI component it may be blocking the output. If that doesn’t work post your files (Revit and Dynamo) and I’ll have a look.

Did it, unfortunately no luck.
In any case, it is so interesting know that the nodes with UI component can cause unknown errors. I’ll train myself to detect it before runing my studies on Refinery.

Here the files .rvt and .dyn of the last test I did:
test001.dyn (35.6 KB)
ConstructionGrids.rvt (388 KB)

I know that the main reason of the topic -the JavaScript error- was kind of solved but if you can help me with this problem about Data.Remember node will be really amazing.
If you think that is the case to open a new topic because it can help the other user to make their researches let me know.
Thank you!

We’ll keep this here for now so as to not confuse stuff but we might move it over once done. I (or perhaps someone else) will have a look soon as possible.

1 Like