How To Remove Dynamo Overlay?

Hello wonderful community!

I have a question about the dynamo overlay that gets placed on revit. There is this blue tint or color that gets placed when you run dynamo and I want to hide it or remove it.

It looks like this:


Is there anyway to hide it or remove it from view in revit?
The only way I found to get rid of it was to close dynamo. I don’t want to keep closing it as I want to run the script again.

Side question:
Why is it when I run a script, the actions it took do not get saved. For example, I create a basic line creation in dynamo and run the script. For some reason when I run the script again the line does not save and gets overwritten by the new line. I tried closing the script and closing dynamo completely but when I run the script again it does the same thing.
My main question is why can’t I save the changes the script made without it overwriting? i.e. create a new lines and keep old lines

I am using Revit 2016 and Dynamo 1.3.2 if that helps. I can also add more pictures to explain what I am talking about.

Hi @Tainted,

The blue lines are the Revit preview.
just untick the Revit Background preview :

For the other question, it’s called the element binding.
Please read @JacobSmall’s great post :

3 Likes

Thank you for your help! Much appreciated :slight_smile:

I kinda understand the Element Binding issue in Revit but it doesn’t seem to be working in Revit 2016 with Dynamo 1.3.2

Things I tried:

  1. run script > close script > open script > disconnect nodes > run script > reconnect and run
  2. run script > close script > close dynamo > open dynamo with script > run
  3. run script > disconnect nodes > close script and dynamo > reconnect nodes and run

Nothing seems to work. Everytime the previous elements or lines in my case just get deleted. Am I doing something wrong?

Hi,

You can also use this workaround to avoid the element binding :
Generate the elements, close the graph, group the newly created elements in Revit and rerun the graph.

I tried the group method and it doesn’t seem to work either. All it is doing now is moving the group :frowning:

Another method is to copy the nodes of your saved graph into a blank new graph.
In this new graph, there will be no element binding.

1 Like

Thank you! This works perfectly. It sucks that I have to copy into a new graph every time but I guess I have no other choice.