How to fix depreciated Archi-lab nodes?

@Kulkul Not sure if I should start a new thread but this seems like an appropriate place, I started Dynamo this morning and most of my Grimshaw package is missing, see below. I should have several more dropdowns, and some of my nodes say Depreciated… Any idea?


@cnealy List down all the versions.

  • Revit
  • Dynamo.
  • archi-lab

Dynamo – Build
Revit – 2018.1
Archi-lab – 2016.13.4

@cnealy Could you show us which nodes says depreciated.

This is the View Templates dropdown node.

Which archilab version are you using?

2016.13.4 – it says this is the latest version on the Package Manager (published May 2017)

@cnealy I am using the same version but i don’t have any issues. Try uninstalling the package and reinstall it again.

@Kulkul that worked – any idea why this would have happened? I was missing all of the node dropdowns above CSV, as well as several nodes inside the dropdowns (ViewTemplate only had Duplicate). My root directory placed this package in our web server instead of locally in my dynamo library, maybe this had something to do with it?

May be. It might be also if you had install any other custom packages that might have overwritten the original one. Could you mark the post as solved. You’re welcome!

Much appreciated!