How to avoid the warning "Your inputs lie outside of the allowable..."

How to avoid this warning:
image

This probably doesn’t answer your question, but I believe that in C3D2024’s dynamo, those are not Warnings anymore.

2 Likes

It’s just a warning because your x and y coordinates are too far from the origin (0,0). You can change the scaling, but I do not recommend that.
image

2 Likes

Ignore it, changing the scaling may result in Dynamo rounding your X,Y,Z values of points, vertices and so on.

2 Likes

Just change the scaling…

Dynamo >> Preferences >> Geometry Scaling

1 Like

Don’t change it

1 Like

Why not? I’ve always changed mine and it runs smoothly.

1 Like

It turns the points previously created at 1026281016294.515186 units to points at 1026281016295 units. As a result the solids move by 1/2 of a unit. This doesn’t feel like much, but shifting 1/2 of a unit here or there for a nurbs geometry will lead to your solids no longer closing, and causing other downstream reactions to things.

1 Like

To fix this you could temporarily transpose the data back to the origin as Dynamo does not like data back too far from origin. Just make sure to transpose again back to real world coordinates before exporting data back to CAD.

1 Like