Error creating solids

Hello, I have an error when generating the solids, this is a script generated by @mzjensen so I do not understand why the error,attached the cad and dyn file

03 Corridor.dwg (2.1 MB)
SOLID.dyn (17.4 KB)

Can you show the error ? Seesm to me that you’re creating the solids. It could be just the warning to change the scale to Large or Extra Large (which you shouldn’t do, well documented issue see here : Object not brought into Dynamo - #5 by mzjensen).

Thanks for the answer, the solids are not generated, you can see it in the output, maybe if you use the dyn and the cad you could appreciate it better

@mzjensen It’s practically your Scrip, could you tell me what’s wrong please?

You can see that the node is returning data so it’s doing something. You likely have an invalid input somewhere, but we can’t tell you what’s going on if you don’t post the warning.


As shown in the screenshot, the solids are being generated. If you want to see them in CAD then you need to add an Object.ByGeometry node.

It keeps generating an error, I am able to use the script more

As @david_licona guessed, your first warning is from geometry scaling. The warning for Object.ByGeometry states that it requires a layer string, but you are providing a number.

@Nick_Boyts from what I understood the first error is only something visual in itself it should not affect, and the second if you are absolutely right I forgot to put it between “”, but that’s it, according to the section that I have, it should generate that in the Dynamo but it’s not like that

I do not understand why in the output it only generates two solids


this is how it should turn out



Geometry scaling can affect the accuracy of your geometry. Are you expecting those jagged lines? If not, that’s likely from the geometry scaling issue and Dynamo having trouble dealing with the precision of your values. That could be enough to cause issues with the solids being created, but it’s hard to say at this point.

I’ll bump this again:

Leave the Geometry Scaling set to medium, even if it looks funny in Dynamo. The data will come into Civil 3D correctly despite how it appears in Dynamo. If you change the Geometry Scaling setting, then there is risk of the data not being transferred to Civil 3D correctly.

1 Like

You are absolutely right, my doubt is because it only recognizes two solids if my corridor contains more solids?

@Christhian set the lacing for the Baseline.PointsByShapeCodeAtNearestStation node to “Longest” as shown in the example.

1 Like

@mzjensen Thank you, it worked perfectly, one query, can you explain to me how that works, or where I can read it, how to find out if that is the problem if it happens to me some other time

This should explain list lacing rather well. The whole playlist is likely worth a watch for you since you are starting out: 05 - Understanding lacing in Dynamo (Dec 2020) - YouTube

Also check out the Dynamo primer - this content is covered there as well: