How do I isolate Type name for manipulation?

Is there a way to get a list of only the Type names without the Family name following? I want to add a suffix to the Type name, but the + node is adding the suffix to the end of the Family name since that is what each item in my lists ends with.
I tried using the Clockwork nodes “Element.ElementType+” and “Element.Name” and both return null values for all items.

@Redrunner262 Did you try using the FamilyType.Name node?

That’s it. Now the Clockwork node “Element.SetName” is not changing the Type names. Now that I have string values for the Type names, how do I set these Type names in my Revit file? In the image below, the red arrow shows the incongruency between the changed string value and the element’s Type name.

@Redrunner262 It’s because you are trying to set the name to the element. Elements won’t have a name. Elements would have a FamilyType so you need to get that and set the new name to that type and not the element.
Try this:

My resulting list in the Element.ElementType node is returning nulls, whereas in your graph it returned the desired data. Do you know why that is?

@Redrunner262 My bad. I think you were already supplying the FamilyTypes. Ignore my previous reply
Can you flatten both the lists and give it a try?

No more nulls but still no change. Maybe in this case it has something to do with the list levels? I see the results of one Flatten node has two list levels and the other has three. Consequently I tried manipulating the levels for both inputs of the Element.SetName node but alas, the results stayed the same.

@Redrunner262 Could you try adding List.Unique node:

Still no change. I’m wondering if the discrepancy in list lengths (shown in red circles) is making the two List.UniqueItems nodes not cooperate together.

@Redrunner262 what’s your revit, dynamo and clockwork package versions?

@Redrunner262 Can you share your whole graph?
Did you duplicate or create these families in the same graph?
I tried the same using Dynamo 1.3.4 and it still works for me.

I can’t attach my Revit file. I purged it continually all the way down to 5 MB, but the 4 MB upload size limit is preventing me from putting it on here. As such, here is the Dynamo graph.

I’m using Revit 2019, Dynamo, and Clockwork 1.33.0.

Categories - Replace Family Type name suffix.dyn (22.0 KB)

Can you send it through Google drive/Dropbox or similar?

See here:

@Redrunner262 Works just fine for me.
Categories - Replace Family Type name suffix.dyn (20.3 KB)

I would suggest install the latest version of Clockwork - 1.34.0, restart Revit and give it a try.

That was it. Thank you!

1 Like