Help with Revit excel problem

I have looked up and tried all of the most talked about fixes for the write to excel error in my scripts and have not been able to figure out why I cannot get Dynamo to write information to Excel.

I have looked for the regedit 1.8 key (only found 1.9, deleted it and still did not work), I have removed and clean installed Office 365 on my machine and it hasn’t fixed it. I also signed into a new profle and that does not affect it at all.

I apologize for the ignorance up front but is there someone out there that could help me figure out why my machine is the only on in our office that has this problem and how to fix it?

I can provide whatever is needed, journal files, .dyn files, screenshots of the dyn files, etc.

I have staff on hand that write their own dynamo scripts and I cannot test them on my machine and I need to be able to.

Thanks in advance.


please upload a dyn file. It’ll be nice to have the problem isolated. i.e. just the nodes that writes to excel. and what does error message say?

1 Like

The .dyn file in question and some specifics about how you’re running dynamo (Dynamo for Revit? Studio? Sandbox?) would be a good start. If you’re in Dynamo for Revit, Did you review the graphics cards settings of excel as noted in the last reply to the other thread?

Sorry for the delay. Just got back in the office. Running Dynamo for Revit. We are trying to pull information into excel to use in several other dyn’s to create sheets, views, etc.

I did not see graphics card setting info. I have read so many threads lately I am not sure which one you are referring to for “last reply to the other thread”.

Write_to_Excel.dyn (26.5 KB)

Here is the excel file that my coworker is using in his scripts:

A - Sheets.xlsx (19.0 KB)

Keep in mind the screen cap above is from an older thread but I am still getting the same error even with the correct file path selected…

Hi @Jaysyn.quarry

Try connecting “0” to startRow and startCol

1 Like

I tried this and got the error still.

The wierd part of all this is that my machine is the only one that will not run this script as is. I tried this on two others machines and the error does not happen…

Check that github link. It explains the inconsistent behavior too.

I just tried the excel graphics hardware disabling. Still getting the same error. =(