Excel.Write to File - Excel not populating after running

do you use bumblebee?

but …i think its similar…

Is this still a problem with Excel 2016? A coworker can run his script with no problem but I get the Excel.WriteToFile errors. We both have excel 2016 and Dynamo version 1.3.2 (latest).

I have deleted the 1.9 registry key like the old 2010 article suggest (I do not have a 1.8 entry, my guess is because my excel 2016 is newer) and I still cannot write to the same file he can on our server. Even if I place the dyn script and a copy of his excel file on my desktop it will not write. I have tried with the spreadsheet open in excel and with excel closed and same error.

Can you post the whole error message?

Jason M. Quarry

BIM Manager


Try feeding a regular 0 into both the start row and start column - not a range nor a transposed list.

Now this might be of interest, we have Office 365. Have others used 365 and NOT had this issue?

Yes I was unable to write to Excel after an Office 365 update, it was resolved after reinstalling. This thread and the one I also linked there have some alternate solutions: Unable to Write to Excel

Does anyone have an idea what in these updates is breaking the write to excel dynamo scripts? Seems like a big pain in the butt for me when trying to keep 20 people running smoothly. Knowing what is breaking it would be a huge relief. My IT department isn’t going to want to reinstall Office everytime an update comes out……

Jason M. Quarry

Have you updated office at some point over the life of the system?

I do find that script off where you are using a range as the starting cell locations. Try that change I previously recommended and see if it fixes things.

1 Like

I will try that here in a few minutes. It is weird though that two of my staff can run it as is with zero errors.

@Jaysyn.quarry you’re not alone in the headaches - Excel Not Responding · Issue #1950 · DynamoDS/DynamoRevit · GitHub

I have made a dynamo graph that successfully writes Revit parameters to an excel sheet. Two problems:

  1. It seems to not re-write if I push Run a second time, unless I close and re-open everything. I change a parameter in Revit, no wait time (as occurs the first time) and no change to the Excel value. I have added a Boolean to Overwrite the Excel.

  2. The Overwrite breaks Excel references from another sheet in the same workbook to the Revit/Dynamo data. Setting the Overwrite to False seems not to make the change at all, which is what I would expect. I need the references to work so the calculations can be updated.

Revit 2018.3, BIM 360 Design, Excel Office 365. Dynamo

  1. This is because Dynamo doesn’t recalculate all items, specifically to avoid long unnecessary recalculations. Alter the connections at your initial selection (ie unwire the category from the all elements of category node, or use a Pass Through method that moves along the category but re-triggers when you toggle a boolean).

  2. Overwrite removes any matching names and creates a new sheet with the same name. If you want to reference the data in a new sheet then you will want to set that to false.

Thanks, Jacob.

  1. For a consistent method and because I won’t be exercising the graph very often (famous last words), I’ll stick with dismissing then restarting Dynamo. I had a look at the Dynamo Player, but the opening screen was inscrutable.

  2. If I set it to false, does it update the data, or is false used for a one-time transfer?
    I’ve made it work by sending the data to an intermediate spreadsheet, pointing the calculating spreadsheet cells to it, then manually updating the data link by pressing a button in Excel.

Thanks again.

  1. First I’ve heard people that confused by the opening screen on Dynamo Player. Might want to check into some of the help documentation as it gets to be fairly clear quite quickly.

  2. Yes the data is still updated, but only for values provided. This means I’d you had 5 rows of data before, and write 3 rows of data back, you wind up with 5 rows of data not 3, with the last two staying as they were.

I tried to play the intro video and got the spinning wheel of ennui. Had to do the three-finger death punch.

More likely an issue with your IT setup blocking the video.

Try just reading this: https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/2017/ENU/Revit-AddIns/files/GUID-BFCE20D2-86D4-4591-8CF3-5405D26DB825-htm.html

Just posting to say that reinstalling Office365 solved the issue for me, thanks all and PHEW!

Had the same issue. A repair the MS office install fixed it.