Help needed to solve the problem associated with null values from categories selection

hi everyone,

I have a problem with my script please have a look at the attachement. My problem is whenever I close my script and open it again all the selections and nodes showed null. I really can’t understand what is going wrong, the surprising thing is I need to replace all nodes again starting from “categories”, “all elements of categories” and “list first ittem” any tips to solve this issue are much appreciated.

Thank you in advance.

Might be the obvious answer… But have you run your graph after reopening it?
Dynamo does not “save” the information in each node when closed, this will have to be run again to populate the nodes. :slight_smile:

Hi Jonathan,

Thank you for comment. I did run the script definitely the scripts was working just fine a couple of weeks ago but at the moment–it won’ twork unlessl I replace all nodes with new ones. However, even by doing that the script will fail to run if I close Dynamo workspace and re-open it again. I am just overwhilmed by it.

Are you running Dynamo in Automatic or in Manuel mode ?

Does your graph contain a ScopeIf node ?

Ok good, just had to get it out of the way :slight_smile:

Check the comment by @mellouze

Have you tried using the SpringsUI.Refresh node to force-run the entire workset?

Hi Mellouze,

thank you for your reply. my script run on Automatic and my script contains If formula-- I don’t know if that has an impact?

Thank you @Jonathan.Olesen

I tried the refresh node that you suggested by unfortunately it changed nothing.

If it is a ScopeIf node (not an If), then a part of your graph (the one not corresponding to the condition you are testing with the node) will not be evaluated.

Anyway, try to set the script on Manual and hit the Run button, see if it works that way.


What i can think of:
open your Revit file with the audit button ticked so your file gets checked/repaired. this might be a good thing to do once per month.
If there is any corruption in the Revit file (like missing Project Information and the button gets greyed out) (seen it, been there)
make sure you check on a copy of the model.


@m.rijsmus @mellouze
hi guys,

Thank you for your comments, I tired your solutions but it didn’t work, i couldn’t figure it out. I just re-written my whole script again and it is working just fine now.

Thank you