Floor by Outline


#1

Last night I tried to explore the floor by outline node, but always get an error.

"the edge list provided does not have an adequate number of edges to create a floor!

I created 4 curves “Autodesk.Revit.DB.Line” where startpoint - endpoint coincide and form, a perfect rectangle.

floor type and level are ok.

what is my mistake ???

edges


#2

Peter, just a thought: Have you tried flattening the list completely before passing it to the node?


#3

Andreas thank you for your advice. Flattenig lists … this node didn’t make it into my memory yet!

The result is … the next error:

“Could not construct a proper face with the input curves to create a floor correctly.”

as you can see:

  • the 3d view shows a perfect rectangle
  • startpoints are 1, 2, 3, 4
  • endpoints are a, b, c, d
  • boundary lines are 1-a, 2-b, 3-c, 4-d
  • boundary lines turn counterclockwise
what is the remaining problem? any clue?

edges2


#4

Strange. I tried two different methods of making a rectangle and both of them work. Here is my graph, maybe that helps.

FloorByOutline


#5

I have a suspicion that the lacing of your nodes is doing something funny and is mismatching the end points of your curves. But then again the curves do form… Tricky situation, definitely.


#6

andreas, there are odd things going on!

as you can see, i rebuilt your definition. same error!

I tried it using revit 2014 with dynamo 6.3 release.

I also tried it with dynamo 0.7 from .06.04.

again the messages?

iam clueless!!!

@ dimitar: seems to be very tricky

-> here is the definition: andreas-nachbau6.3
andreas-nachbau


#7

I managed to do it with a regular floor type.

check your floor type. the structural one did not work on 2013 and I also had to change the Lines through points node but the rest worked

see attached

andreas-nachbau6.3


#8

jean-marc,

thank you!!!

the only thing i didn’t check was the floor-type itself, just used the first popping up!

did cost me some hours… but improved my dynamo and my python skills!

I owe you one!

 


#9

Interesting. Maybe worth filing a support request for structural floors on GitHub.


#10

How do you distinguish between “Structural” and “Architectural” floors?

In the building suite version there’s a structural tag for each floor instance. Not sure how it is with non BS versions of Revit.

The tag:

2014-06-09_153545

There’s also the option to define the layers in a floor as structural:

2014-06-09_153605

I made two floor types. One had only a structural layer, the other all other layers. It works for me in both cases, however the "Structural"tag is automatically untagged upon creation without getting any errors. So I am not entirely sure if the floor type is the issue here.

2014-06-09_154335

 

 

 

 

 

 


#11

*to precise which one works and which one doesn’t.

this one doesn’t but shows up in the floor types list. it is a fondation slab / radier in Fr

 

Capture


#12

Thank you for finding the problem with structural floor types. I’ve filed an internal bug report.