Familyinstance.bygeometry incorrect solid of family

Greetings dynamo community.

I am trying to create some volume [generic families] using springs package/familyinstance.bygeometry node. I am running some issues regarding the created families. It looks like the “solid” is corrupted.

I Ran the scripts from both dynamoplayer and dynamo but got no results. As follows :

The MeshToolkit package may have some nodes to help you out
Also, there is also a node to convert Dynamo mesh objects to families.

Its a very old post i know, not all pictures and links will work, it’s from the old Dynamo Forum. sorry it got lost,

Hello Marcel, thanks for the replay. I tried also with directshape but no luck.
Now i rewrote a little bit the script.

The volume now looks like a brep without the base surface :smile:

There many things you can do with the MeshToolkit nodes
There is a make watertight node i think.
You need to crate some extra Dynamo geometry to do so.
That’s where the fun begins :slight_smile: