Extending Dynamo Background Grid for Millimeters Users


Am still learning how to fully utilize dynamo in Revit. Currently I’m having troubles with background display failing to extended at some point. I like to work with the grid on as it gives a sense of a planar plane (Just as in other modelling programs)

See, am using millimeters as a unit of measurement in Revit.
My past experience was that, if i change my units to meters (which means 20m Revit =20 units Dynamo) I could still see the background grid. Now I have began to apply it in real scenarios hence am required to use millimeters from the beginning.But at 20m (20,000 mm or 20,000 units Dynamo) I can’t see a grid


Can some advice me how to properly use it (especially someone who is using millimeters as unit of measurement in Revit). Is there something I’m missing or doing wrong?. Is there a way to extend it like in 3ds max or Revit?

@noelgustav There is currently no option to manipulate the background grid.
However you could make a request for such a setting here

This PR might finally make the grid and other Dynamo objects scalable: