Problems with units when exporting from Dynamo to Robot

I have a problem when exporting the geometry from Dynamo to Robot using the Analyze package. My units in Dynamo is in millimeters, and the export to Revit Works perfeclty fine:

As you can see, the units are both in millimeters.

But when I try to export the Dynamo geometry to Robot, it always appears in meters. I tried to change the units to millimeters in Robot before running the Dynamo script. But it just appears in the scale showed in the Picture:

Robot just adds 10^3 to my dimensions.

Thanks for any help!

Hi @571488

Try to save your mm units in a template and close both the robot and dynamo and reopen them
I used to have a similar issue and every time I had to repeat my analysis I had to break the connection between dynamo and robot by closing and reopening them
I hope this could help you


1 Like

Hi @Jaafar_Al_Nasire,

Thanks for the reply!

I have tried to save a new Robot template With mm units. Then i closed the Robot template (Shell Design) and reopened it. I runned my Dynamo script and the Geometry appeared in both Revit and Robot. The Revit modell works just fine as before, but the Robot model is still in meters… Do I have to convert my output With a node or something, when exporting my model to Robot? I thought this was going to work… Strange…

Or is it any problemwWith the template i am using (Shell design)?

Thanks again for any help!

1 Like

Hi @571488

can you send me you Revit dynamo robot files?

Hi @Jaafar_Al_Nasire
I just converted the units from millimeters to meters in Dynamo, before sending the model to Robot. It Works just fine!

1 Like