Problem with Units?


#1

I am running through the video tutorials, and the “Parametric Assembly Part 1” video is using a Revit file that is in imperial units. In the video, it appears that imperial numbers are entered in the number node that defines the position of the points (0…165…#count), and it works, but when I input the same numbers the scale is way off - the dynamo curves are revealed to be much smaller than what is in Revit. I cannot place the adaptive components because the scales don’t match.

It seems that Dynamo is in meters and the Revit file is in feet and I cannot figure out how to get the units in sync. The “Length Display Units” on the Settings tab does nothing.


#2

I was having the same issues. Very frustrating. I just converted all my constants to metric.


#3

Have you used the Settings pull-down menu at the top of the Dynamo window to specify your preferred display units for Length, Area and Volume? My experience has been that when starting a new file, it defaults to metric. I also found that if I forget to set imperial units before placing nodes and running the file, I will get metric units and at that point changing the settings to imperial does not immediately change the results, even after hittin “Run” again. After changing the units to decimal feet, if I save, close, reopen and “Run” the Dynamo file, I do see the change to the displayed units.


#4

I am having the same problem. I was not able to get it to work by setting the units to decimal feet, saving, closing, reopening, then re-running the file. I have also tried starting a new file from scratch and making sure to set the units properly before starting.


#5

i’m having the same issue. nothing seems to fix it.


#6

Bump, please… Still having this issue. Trying to offset a curve, but the “distance” only works as a “number” input, which the default is in meters. Converting the “number” to a foot distance no longer works with the “curve.offset” node,


#7

Hi Marissa,

You are correct that Revit conversions from Dynamo are through Feet. So what you will need to do is convert your numbers to Feet if you are adding in Metric values in Dynamo to adjust Revit components.

Now since 1mm=0.00328084 foot any value that you want to input, you should attach a Codeblock before you input the value into a node with the formula:

  • x*0.00328084
This will enable any value you set in Dynamo to a parameter to be converted before running in Revit. Sample Images below.

 

C9

c10


#8

Looks like this issue has been fixed in the latest release. .8. So much better!