Excel to Revit sheet Creation Help

Hello, I am still a beginner with Dynamo and i was wondering if anyone can help me figure out what i am doing wrong to get this script to work. This Excel to Revit script was posted online by Brendan Cassidy. I have followed everything the manual says to check but it still gives me errors.

Can anybody tell me what i need to change to get the script to work please ?

Sheet Creation From Excel v0.2



Thank you your Time

The groups Ao, A2 and A3 show errors as you are feeding it empty lists

As for the group A1, it seems like you are feeding in numbers in many cases where the nodes expect strings.

Try converting them to strings (using String from Object) and see if it works.

Hi Keiran,

Try Vikram solution and if it doesn’t work. Can you post here screenshot of errors your getting from your side.

Hello, I have a feeling the errors might come from the excel sheet but i could be wrong, these are my errors when i run it:



































































Nothing wrong with your Excel sheet.

To solve one of the issues either follow my above suggestion or if you’re using any of the recent versions replace the excel read node with this…




I have now revised and released a updated version of the script in question, just refer to the following for information.

Timelapse of the script: https://twitter.com/brencass86/status/732709808302919682

Script download link: https://twitter.com/brencass86/status/733082159611809792

1 Like

I have done another update to my Excel to Revit Sheet Creation script and it can be found in the below link

Hi Brendan,

Just been looking at your script here (not tried the very latest version yet) - the two things I’ve found that help resolve the errors with the sheet creation was the addition of boolean (true / false) node to the ‘readAsStrings’ input with this set to true. The other thing was to specifically set the view to be loaded onto the sheet to a drafting view - for some reason just about anything else seems to give me an error. Other than that seems to be working as expected. Just a few wee tweaks to make for my own requirements now.

Actually I still have a problem. The sheets are being created okay and the name and number are set correctly however the sheet parameters are only getting set on the first sheet created, noting of the others (see image).

The data itself seems to be fine it’s just not populating correctly - can’t for the life of me see why…


If your drawing list looks like the following then you are using the wrong dyn file because it just uses the last section of BS1192 for the sheet name and then you would get sheet name already in use. This will indicate you need the joiner version of the script.

To use the script you have highlight above then, you would need to have your register as follows.

Note: There is two scripts within the zip file to cover both situations and you will need to look at how you are implementing BS1192 prior to deciding which script to use.