Error when using Dynamo player, but not everytime

Hi all,

I sometimes get an error when i try to batch plot files from revit via dynamo player.
The message is as follows:
image

My best guess is that this is because i have dynamo 1.34 and 2.03 on my pc but i am not sure…

Can anyone help me out what is happening?
Dynamo player just keeps loading when this message shows up until i force exit,

@MVE1112 I believe your Batch Plot Dynamo file has been built using 2.0.3

But since you have 2 Dynamo versions, Revit would by default launch the 1.3.4 for Dynamo player
(if you never opened Dynamo 2.0.3 in the current session)
And since your file needs 2.0.3 and not 1.3.4 you will end up getting this error.

So in order to avoid this issue, you can:

  1. Uninstall 1.3.4 (if you don’t use it)
    OR
  2. Always launch Dynamo with 2.0.3 > Close the Dynamo window > Launch Dynamo Player > Use your Script
1 Like

You are correct, i have built it in 2.0.3.
This error only occures when i open Dynamo player before opening Dynamo and selecting version 2.0.3.

Dynamo player runs fine if i first open the script in dynamo and then open dynamo player.

I have no use for 1.3.4 so i will uninstall that.

Just to be clear: Dynamo player launches in the earliest version unless you have opened a later dynamo version this session? Or how does this work?

You got it right.

@solamour @JacobSmall @john_pierson should be able to confirm but I believe that’s what it does.
Also, is there any hack/setting to define your default version?

1 Like

Uninstall 1.3.4

3 Likes

Thanks for the quick help!
Will be uninstalling 1.3.4!

This, 100 times this. All of this. EVERY TIME this.

3 Likes