Error when starting, Dynamo "de-installed" itself?


#1

DynamoInstall0.7.2.20140926T0043

on a win 7 enterprise, 64 bit with admin rights keeps “de-installing” over night.

 

dynamoseldeinstall


#2

Thank you. Of course, any more information you find, the better. Tracking internally as MAGN-5083


#3

Thorsten,

Can you provide a little more information? Are you leaving Dynamo running? Is the Dynamo application still available on your machine (i.e. go to Program Files\Dynamo and check if it’s there). Is your system in an environment where there are any sort of nightly tasks that might cause the Dynamo installer (which also uninstalls previous versions of Dynamo) to execute?

What version of Revit are you running on?

Ian


#4

I’m getting the exact same error here for 0.7.3…also having an issue with the DynamoRevitDS.dll disappearing from it’s source folder for both Revit 2014 & Revit 2015 R2. Thorsten did you solve this problem? Same win 7 enterprise, 64 bit but without admin rights (IT controlled which probably doesn’t help at all).

Thanks,

Lewis


#5

Dynamo does not have any installer behavior that would cause it to de-install itself overnight. Can those who have reported this problem please check with their corporate IT to ensure that some corporate clean-up utility is not trashing Dynamo?


#6

Looks like I found the issue; it was conflicting with some CASE add-ins I also had installed.

Lewis


#7

Lewis,

Thanks for the update. We have an issue that we are tracking around plugin conflicts. We will have a fix in the Dynamo version AFTER 0.7.4. Thanks for the feedback.


#8

To close the loop for others that might stumble up on this thread. The issue seems to stem from certain users’ computers antivirus settings. Symantec, in particular, will delete dlls that it doesn’t see much in its database under the mistaken assumption that they are a virus. We cannot provide a solution for this from the Dynamo side. If you have an issue where the dynamo dlls go missing “nightly”, please work with your IT to add an exception to your anti-virus settings to allow dynamo to live on :slight_smile:


#9

I just patched my Revit 2015 yesterday, installing UR3, R2, then UR7. Today, both 2014 and 2015 are missing the dll. I’m going to run the dynamo 7.5 installer to fix.

dynamo_dll_missing


#10

Could’ve been the patches? I already had 7.5 installed.

Running the 7.5 installer fixed it.


#11

I think that one of the patches included Dynamo 0.73 and if you had a later version, it got overwritten with the old one. That could lead to a jumble of old and new files.


#12

Sorry for the (very) late reply!

Our IT system to deploy software packages in the office was causing the funny behaviour.

(it keeps installation resources but in this case didn’t keep the last but second last one and every morning decided to do some roll-back)