Dynamo 2.0.3 error installation

Hi everyone.
I have a problem with the installation of Dynamo 2.0.3 in Revit 2019.
If I open Dynamo 1.3.3 in Revit it warns that there is a new version of Dynamo avaible. So I try to install the latest version but when I launch installation, it fails with this error:

image

Any help???

Delete all dynamo’s. Backup your nodes. Install 2.0.3. Should work.

1.3 is heavily outdated, try avoid using by all means. Convert all your scripts as you use them.

thank you for the answer.
I’ve deleted all dynamo from pc, and I’ve tried to run Dynamo2.0.3.exe but the error still remains.

I had same problem in Revit 2018 and I thought it was a problem of 2018 version but with 2019 it remains.

Please there are other possible solution?

Have you tried installing 1.3.4? Also, have you installed all the latest revit updates?

I’m not personally sure about the error as I’ve not come across that particular problem but @JacobSmall might have an inkling?

Use the uninstall feature of windows to remove all types of Dynamo across the entire system - no sandbox, no Dynamo for Revit, no Dynamo Studio, No Dynamo for Civil… no Dynamo at all. Then frown because no Dynamo means more manual work. Then open your registry and confirm there are no dynamo entries in there - if you see any delete them and frown again. Restart your cput, and then download and install Dynamo 2.0.3 and only Dynamo 2.0.3 (avoid the 1.x and other 2.x flavors for now). Launch Revit, launch Dynamo for Revit, and let us know if it works.

Thank you Jacob.
I haven’t any type of Dynamo in my system. I have searched and deleted in my registry but when I launch the file .exe of Dynamo 2.0.3 there is the same error and I frown :worried:
Do you think there are other entries that I haven’t able to find?
I need Dynamo 2 for my work…what other can I do?

Does the installer fail or is this after trying to open Dynamo?

the installer fail

Oh I misunderstood. That is quite a bit different, and I don’t really know where to start. Perhaps @Michael_Kirschner2 could shed some light?

Hi @leoflazio - unfortunately I have not seen this before - what language do you have windows set to? Can you try temporarily setting your system region, language, etc to english and trying the install?

Thank you Michael.
I have italian language. I have tried to change in English and install but the same error remains.
Please, do you have others suggestions?

I’d say try deleting all the software from autodesk and reinstalling on cleaned system. If the issue preciest then the problem is with other software on your computer. It’s quite overkill to reinstall all, but this way you’ll know for sure. And if this is the case and you desperately need dynamo/revit, you can try to look for the program/setting that causes the headache. Alternative would be to just reinstall windows, clean.

So I hope @Michael_Kirschner2 can come up with better solution for you.

well, without more info I can try guessing…

  • do you have very long path names on the machine?
  • is the user name long or does it have spaces?
  • when does the install fail?
  • what version of windows?

Sorry Michael, before answering at this questions, I have found a Dynamo Core 2.0.3 folder in C: but in the uninstall feature of windows it doesn’t appear :open_mouth: so when I deleted all versions of Dynamo I didn’t see it.
How can I unistall it?
Anyway I have a space in the user name, Windows 10 and the install fails when I launch the file .exe and I get administrator permission.

are there actually files left in there or is it just an empty folder?

Can you try making a new user and installing using that user as a test.

There are files in the folder and a Dynamo Sandbox.exe and if I open it runs.

Can you try deleting it and then cleaning up the registry - you can follow these instructions pretty closely:
https://dynamobim.org/working-with-dynamo-in-revit-2016-and-revit-2019-simultaneously/

1 Like

I have followed the instructions and finally the installation starts and I select this components:

dy

The installation ends without problems but in Programs and features there isn’t any Dynamo and in C: > Program Files there is a Dynamo core folder with only a readme file inside. Also in Revit there isn’t Dynamo.
Please, another help? :pray:

If I were you I’d be long reinstalling the whole system.

I purge once a year anyway, to remove accumulated leftovers.

But it just me. I still hope somebody can help you with a better solution. :v: