Dynamo crashing at Startup

With this error:

How do I get Dynamo running again?

Hi Aseem,
Did you try restarting your PC?
Do you have previous Dynamo versions installed?

Hello Kulkul,
I did restart the PC.
Initially I had multiple versions of Dynamo Installed. After reading your post, I uninstalled every single one. Then Reinstalled the last I had downloaded yesterday - “DynamoInstall1.1.1.20160804T1248.exe”. Then I restarted again. This is what I have currently installed:

But still having the exact same issue, with the exact same error popping up.

Report your issue here https://github.com/DynamoDS/Dynamo/issues

HI Aseem,

Looks like you are running one of the bleeding edge Daily builds, wear a hardhat! We’ll look into the error, but you should either roll back to an earlier daily, or keep using the regular 1.1 latest stable build

Thanks for the reply. It appears the installer for Aug 4th build has deleted (or modified) something critical. Because I tried rolling back, going backwards through several different builds - all of which have worked in the past, till I installed the build from Aug 4. Now, no matter how much back I go, I get the same error, just with a different build number in it. Please help! I am completely unable to use Dynamo in Revit 2015, 2016, and 2017.

Try this. Uninstall Dynamo Core and Dynamo Revit in your Remove Programs

And manually go and remove the contents of this folder for good measure:
C:\Program Files\Dynamo

Then reinstall Dynamo 1.1.0 (or another daily you have had a good experience with)

Well…that is exactly what I did. several times. Still having issues.

Whenever i have that problem I run Dynamo sandbox , then try to open it from revit again. I really don’t know why but it always works .

where can I find Dynamo sandbox? Are you talking about Dynamo Studio?

C:\Program Files\Dynamo\Dynamo Revit\1.1
I’m talking about the free version of dynamo for revit

It looks like Dynamo Core is not properly installed. Can you please check if DynamoCore.dll is available at C:\Program Files\Dynamo\Dynamo Core\1.1\

If it’s not there, I’ll suggest that you first uninstall DynamoCore and clean up the Dynamo Core installation folder and then install the stable build of Dynamo 1.1

If DynamoCore.dll is available then you may try launching DynamoSandbox.exe from C:\Program Files\Dynamo\Dynamo Revit\1.1

If DynamoSandbox.exe runs fine, then we need to check if any of the Revit dependencies are creating any issue.

DynamoCore.dll is present in C:\Program Files\Dynamo\Dynamo Core\1.1\

I am able to successfully launch DynamoSandbox.exe

After launching Dynamo Sandbox, I am still not able to use Dynamo through Revit, like one of the previous posts is suggesting.

@Aseem_Deshpande, I understand it is painful when you encounter such an unexpected issue, thanks for trying out various diagnostic steps.

You can dump the list of files installed with Dynamo Core 1.1 on your system by going to folder C:\Program Files\Dynamo\Dynamo Core\1.1 calling following command from command line.

dir /b /s > c:\temp\dynamofiles.txt
You can compare your list of files with those of mine attached here and check if all the files are installed properly.
dynamofiles.txt (47.0 KB)

To understand the problem fully we need to find out the missing dependency. Can you please try out following troubleshooting and let us know the missing dependency? http://www.codeproject.com/Articles/560816/Troubleshooting-dependency-resolution-problems-usi
Meanwhile, please also let us know the Revit plugins loaded in your session, so that we can try to reproduce the issue at our end.

The text file looks pretty much the same, but I don’t know what I should be looking for. I am attaching the text file from my machine for your reference.

Also, I am attaching an image showing all the addins installed. I guess that is what you are intended when you say “Revit plugins loaded”.

adeshpande_dynamofiles.txt (47.0 KB)

@Aseem_Deshpande can you please mention the name of the add-in that was causing conflict during the start-up and uninstalling that add-in fixed this issue.

Sorry for the much delayed response, I simply missed your post here.
The add-in that was causing Dynamo to crash at startup was called Colorizer. Once that was removed, Dynamo has been running fine.

Hi Aseem,
This is to share that how i get rid of the same situation in other way and it might help the community.
i was in same situation for revit 2017 and related many dynamo builds were crashing at start up but i was able to run only dyn .8 on rvt 2015. i observed this topic and followed every means suggested…especially i uninstalled all add ins for rvt 15,16 & 17 but the situation was same for every rvt and dyn versions.
I reported this issue on github also-[DynamoDS/DynamoRevit] Dynamo is great but tired off crashes. (#1008)

There was an indication for graphics card though not told deliberately. I was also suspicious if it was for GC. And it was…i put a extra GC on my PC and dyn 1.2 is running well with rvt 2017 while without any add ins. Now it is to see if it is crashing when add ins will be installed!

All the best :slight_smile: