Dyno can't find Dynamo on Revit


#1

Hey guys,

I have an issue with my Dyno Browser. When starting Revit it says that it can’t find Dynamo and it also isn’t available on the Add-Ins tab anymore. I have been trying installing Dynamo 2.0 and Revit 2018 which I think has caused the issue. I uninstalled Dynamo 2.0 from my machine. Uninstalled and reinstalled Dynamo 1.3 and Dyno Browser. But still the problem hasn’t been fixed.

Note that Dynamo 1.3 is available and working on Revit but Dyno Browser can’t find it and therefore it doesn’t even appear in the Add-Ins tab. The message I’m getting is this:

2018-01-11 10_59_38-

Anyone got the solution? @Aleksey_Lobanov


#2

Sounds like a version conflict. Uninstall all versions of Dynamo and reinstall just the 1.3 stuff.


#3

I did. Still no luck. Is there anything that I have to manually remove after uninstalling? :thinking:
Cause I have noticed the Dynamo Core X.X ones remain uninstalled even after you uninstall Dynamo. As a result I have a bunch of Dynamo Cores for different versions I have installed and uninstalled.


#4

Uninstall the cores and the Dynamo for Revit and Dynamo studios… basically all of everything.


#5

How do you uninstall Dynamo Cores?

2018-01-12 16_37_53-Settings


#6

try first the uninstall app from autodesk, than the windows deinstallation and than delete the remaining dynamo folders


#7

Just tried uninstalling everything. Followed this procedure:

uninstall everything (including deleting any folders associated with Dynamo) and run Microsoft fix-it (download from https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed).

uninstall and delete all the folders found in the following:
-> Program Files\ Dynamo (everything in here needs to go)
-> Autodesk\Dynamo Studio 201x (if you have this)
-> ProgramData\Dynamo
-> Users\yourusername\AppData\Roaming\Autodesk\Dynamo Studio (if you have this)
-> Users\yourusername\AppData\Roaming\Dynamo (be careful, you may want to make copies of these folders elsewhere as these are where your custom nodes and packages are stored)

Then restarted the machine! reinstalled Dynamo 1.3.2 and then Dyno 0.6.2 (latest).

The issue still persists!


#8

Do you have any other plugins? Sometimes the plugins creating problems.


#9

I do have quite a few. But do I really have to uninstall and reinstall everything? Is there not a config file somewhere I can get to point to the Dynamo location that is unable to find? @Aleksey_Lobanov


#10

Just an update on this. After doing all the above I uninstalled my Dyno which was 0.6.2 and installed the current version 0.6.6 and it seems it has solved the issue.


#11

Thanks a lot! I had the same problem as you, and solved with the method you provided.