Error opening corrupted file

Dynamo, Revit 2019.2.2

Anyone know a way to troubleshoot this? Thanks!

CR_Copy Occupant Load Factors.dyn (52.8 KB)

Your screen shot is showing that the version you are trying to open it in is actually 1.3.4. The red text is showing you the latest version for your build of Revit (2019).

Opening a 2.0.x graph in 1.3.x will give this error.

One thing that may have happened is you ran dynamo player and it defaulted your dynamo to 1.3.4, so a fresh revit restart and a launch of 2.0.3 will fix it.

Edit: Also, it opened fine for me in 2.0.3


Okay. Cool. I figured it was a version thing but wasn’t sure. Will reopen Revit.


Tried that and it still did the same thing. Any recommendations on getting the right version of Dynamo to open in Revit? Noticed the green download cloud was highlighted telling me there’s a new version of Dynamo available, would that help solve or worsen the issue? Along those lines, how do I make sure that Dynamo Player looks for the correct version of Dynamo?


Uninstall 1.3.4 and reinstall 2.0.3 (Revit 2019)

1 Like

corruption issue solved now have a couple of nodes acting up:

The string to number error is:
Warning: String.ToNumber operation failed.
Not a valid number.
Parameter name: str

and the Element set parameter by name error is:
Warning: Element.SetParameterByName operation failed.
The call is ambiguous between the following methods or properties: ‘Revit.Elements.InternalUtilities.ElementUtils.SetParameterValue(Autodesk.Revit.DB.Parameter, Revit.Elements.Element)’ and ‘Revit.Elements.InternalUtilities.ElementUtils.SetParameterValue(Autodesk.Revit.DB.Parameter, string)’

Hey Travis, can you expand the output of the “GetParameterValueByName” node? I think there is probably a blank value or a value that is not a number in there. Also if you had a simple RVT that replicated this, that could be helpful.

Essentially, I think you need to do a string.replace on that output to take out some of the values that will not work.

Here is an example of why it would fail:

1 Like

Data appears to have shown up in Revit model correctly… Statisified enough for deadline but will look into it again when I have a moment. Thanks!