Dynamo crash error code?

revit
dynamo

#1

Hello forum!
I get this error code at least 1-2 times a day when working with Dynamo. I have tried to Google it but can not find any solution to the problem… Can some of you spot what the problem is and how to solve it…?

Udklip

Thank you for any kind of help! :slight_smile:


Corrupt DYN file, crashes Revit on opening
#2

Hi :slight_smile:

Many have encoutered similar errors. I believe this one comes from the fact that you are trying to open a graph developped in Dynamo 2.0.1 with Dynamo 1.3.


#3

@mellouze Yes but I only work in Dynamo 2.0.1… :thinking:


#4

Then check if your Revit version is delivered with Dynamo 1.3 or Dynamo 2.0.1.I think that some versions of Revit 2018 are delivered with Dynamo 1.3 whereas others are delivered with Dynamo 2.0.1 :slight_smile: Changing Revit versions may change Dynamo versions somehow.

Hope this helps


#5

I have seen this error couple of times. This was solved many times here. I can’t collect his name :thinking:


#6

I will try. :slight_smile: It is a firm version and it comes with Dynamo 1.3 standard. The 2.0.1 version is downloaded afterwards.


#7

If you do remember it would be great! I have scrolled different posts in the forum through, but have not found similar problem?


#8

Do you have any packages which are not 2.0 compatible? Are you running in automatic or manual mode?


#9

@JacobSmall Immediately are the packages pretty standard, like archi-lab, clockwork, data-shape and so on. And the golden rule when working with Dynamo is always set ‘run’ to manual. :slight_smile:
But I yesterday I found out that if I click:

Revit -> Dynamo canvas -> Open Dynamo Player -> Close Dynamo canvas -> Work in Dynamo via ‘edit’ in Dynamo Player, then it works…? :thinking: Strange…


#10

I suspect you’re trying to open a file saved in 2.0 into Dynamo 1.3x. The xml reader fails at the very start of the file, because 2.0 files use a totally different encoding.


#11

Hi @Dimitar_Venkov. Well actually not. I have both 1.3 and 2.0 installed but have never used dynamo 1.3. Maybe if I uninstall the 1.3 version?


#12

Seems like a package is out of date. Be sure you’re using the most recent version of each on your 2.0 build, and the last workable 1.x version for your 1.x build for each package.


#13

Thanks @JacobSmall. That solved the problem! :slight_smile: Solution marked.