Issues passing solid geometry between Dynamo and C3D document

The object.ByGeometry node was working as expected but recently started returning null for solids when trying to pass them back into ACAD. This happens no matter how the solids were created (the solids were visible within Dynamo).

I then uninstalled C3D and Dynamo as suggested in this thread Object.ByGeometry returns null which did not resolve the issue.

I have also noticed that the Object.Geometry node returns the error “Warning: Object.get_Geometry operation failed.
The file exists.” when attempting to create dynamo geometry from acad solids. The node works perfectly fine for other, 2D geometry.

The issue appears to resolve when running C3D as another user (admin) but is still present using a normal user account.

I’m really baffled by this one !

image

Hi @elliotgr2010

Could you drop here dwg file?

Sure - This happens with every dwg no matter how complex or simple the solids. I’ve attached an example with a single basic solid.

SolidIssue.dwg (1.7 MB)

Looks good to me:

What’s the geometry working range you’re using inside dynamo?

Thanks for your PM ! Unfortunately it wasn’t a geometry scaling issue either

To elaborate on my original post the issue occurs when creating Dynamo solids from ACAD solids and when creating ACAD solids from Dynamo solids. The Issue is only occurring with 3D solids - all other geometry is fine.

This is occurring with every .DWG and even the most simple solids (as demonstrated in the images below) across a range of different coordinates so is not a Geometry scaling issue.

I should also add that solids passed between Dynamo and ACAD without any issues up until a couple of days ago.

The issues only seem to occur when running on my normal user account. If I run C3D as another user (an administrator in this case) - there are no issues at all.

Steps I have tried so far:

-Uninstalling C3D and deleting the folders from my C;/Users/User/AppData folders and reinstalling C3D
-Uninstalling Dynamo and reinstalling dynamo
-Updating C3D to 2020.3

None of the above steps have solved my issue.

See below for an example of the issues i am experiencing

Attempting to create Dynamo solids from ACAD solids (in this case a simple cube
)
image

Attempting to create ACAD solids from Dynamo solids - Returns null when using Object.ByGeometry

Any ideas with this one would be greatly appreciated as it is a bit of a show stopper for me !

how big are the coordinates you are working with? I have found translating objects closer to 0,0 (x, y) origin helps with creating AutoCAD solids from abstract Dynamo geometry. In AutoCAD I typically move everything using a .scr file similar to below.

-layer
U
*

_ai_selall
move
D
-1,-1,0

I eventually managed to resolve this with some help from @Kulkul and removing my networked account locally from my PC.