Dynastandard config

I cannot open files via DynaStandard using my work computer. Maybe for using the server…
I’ve tried putting it in different folders, but the same error happens.

Screenshot_1 !

@Behling, I am the person that created DynaStandard.

Could you attach or send me a link to download your setting file and a screengrab of your folder structure so i can try to re-create and debug the issue. Then if i need to create a fix i can do it in the next version which i am releasing at the end of this week :slight_smile:

Note: This new version does have some fixes and a UI changes to the python template windows :slight_smile:

1 Like

Cool :grinning:
(The file was also added to the files and programs folder, as per “readme”. However, the “readme” has only the folder structure for when the dynamo was installed separately - revit 2019, 2018…)

setting file: https://we.tl/t-rnl1MLheLh


It would see that the path you have put in for DynaTemplateLocation is the issue here, you have “& amp;” at the start of a path and this is causing the whole thing to break. This is because there should not be a space between “&” and “amp;”.

Also looking at your folder structure there is no a reason to have the special character at the beginning anyway. Therefore relook at all the paths within the settings file and give that a try.

I recreated the same folder structure on my personal computer and it’s ok. The problem occurs when the structure is inside the server.
(I put the & amp; because the folder name had a special character “VZ & Co”.
The space between the “&” and “amp”, was in just one of the structures. It was my carelessness.)

I was highlighting the space mistake because that was giving me issues when trying to debug where there was issues.

If you need a & in a path you then replace it fully with “&” with no spaces. You add the spaces after the ; and before the & if you need them.

eg “New & Folder” would become “New & Folder”.

On the point about the server, i and others have used it to path to a central mapped drive and it has worked. Will still have a look.

Thank you!!
I will try to review the steps.
On my personal computer it was very simple and I had no problem. :confused: