Issue setting the default Python template

Hello,

I Followed the tutorial on this link here:

https://primer.dynamobim.org/10_Custom-Nodes/10-6_Python-Templates.html

This is my Python Template:

And this is my DynamoSettings.xml File

These are the exact same steps explicited in the tutorial… but it didn’t work for me.

Can anyone please give me a hint?

Thanks!

Hi @ramoon.bandeira

Try removing from start and end and also continue on the same line <PythonTemplateFilePath>C:\Users\Appdata\Roaming\Dynamo....

Tryed that. Unfortunately it didn’t work.

Try :

<PythonTemplateFilePath>C:\Users\chuong.ho\AppData\Roaming\Dynamo\Dynamo Revit\2.1\PythonTemplate.py</PythonTemplateFilePath>

Or :

<CustomPackageFolders>
    <string>Z:\DYNAMO\PythonTemplate.py</string>
    <string>C:\Users\mka\AppData\Roaming\Dynamo\Dynamo Revit\2.0</string>
  </CustomPackageFolders>
  <PackageDirectoriesToUninstall />
  <PythonTemplateFilePath>Z:\DYNAMO\PythonTemplate.py</PythonTemplateFilePath>
  <BackupInterval>60000</BackupInterval>

PythonTemplate.py (924 Bytes)

2 Likes

Using your guide and setting those properties to the %appdata%/Dynamo/DynamoRevit/DynamoSettings file, solved my problem.

Thanks a lot!!!

1 Like