DynamoCore.dll Unresolved /Orchid Package Issue After Every Restart

I’ve been having this issue with the Orchid package over the past month. Before anyone asks I brought this up on the Orchid Github and we weren’t able to figure out what was going on so I thought I’d try here. erfajo of Orchid hasn’t been able to replicate this problem.

Every time I restart my computer and try to open a dynamo script with orchid nodes I get this error on the nodes:
Unresolved core 01

I also get this on the Workspace dependency. Note that I’m using 230.0.1. The older version shows up as red even when the package is working. Same with Genius Loci, it is displaying an issue with an old version but the nodes in the script still works.

Workspace 01

If I run the executable provided on the Orchid Github it begins to work again, but only for the day. Once I restart the computer it becomes broken again. I used to be able to manually copy the package folder to make it work but that is no longer the case. Only the executable solves the issue now.

We’ve tried to remove the some .dll files in other packages that might be interfering with the built in .dlls. Simplex has several .dll’s that are located in the DeynamoForRevit folder by the way. That did nothing.

We’ve tried deleting a few specific files form the Orchid package that might have caused the issue but that didn’t help.

Has anyone else had a similar issue to this?

I’ve tried to figure out how to reinstall 2.3 but couldn’t find anything. I figured that because it is installed as a part of Revit I could just try reinstalling 2020. I’m skeptical that it actually reinstalled 2.3 however because the recent documents in Dynamo were the same as from before uninstalled and installed Revit 2020.

Yesterday we tried it on another computer. We have a batch file that will copy packages from my user profile and put it on another or all revit users profiles. I made sure I had a working version on my profile and then ran the script on our test user. I logged into the test user on another pc and the orchid package worked there. I then restarted that machine and logged into the test user again and the orchid package worked again.

We thought that maybe it was something on my machine so I made sure I had a working version of the package by running the orchid install and then restarted the machine to send my profile to the server. I logged into another machine and the orchid package did not work. I fixed it on that machine and restarted and then logged back onto my normal pc and the Orchid package wouldn’t work. It seems like there is something that is going on with my user profile.

My IT person then renamed my profile folder on the server so that it would recreate it when I turned off my machine. When I logged back on Orchid wasn’t working once again.

IT appears that this may not be an issue with other people which will be nice because I want to start to get people used to working with dynamo more, but it is going to be a real pain having to reinstall the Orchid package every day.

I made sure I had a working version and copied my 2.3 folder to my C drive and changed my package location folder in dynamo. Restarted my machine and the Orchid package works. It will not move around with me but I rarely log into other computers. I may stick with this if I can’t find a better solution.

1 Like

I mentioned my possible solution to the IT guy and he asked if there was any downside to just changing everyone’s location to a folder on the C drive. It would make distributing the packages easier, so is there any downside?