Dynamo Update to 2.0.1 - Dynamo Core and Revit have different versions:


I updated Dynamo to Version 2.0.1 and now some nodes are not working. It seems like it is cause there are two different versions of Dynamo:

How can I get the same versions for those?



hmm, same issue as:

can you say what setup you had installed and then how you updated?

Also as a first debugging step can you remove all dynamo packages.

can you also try to use the node PolyCurve.ByJoinedCurves() and show what happens - thanks.

@Racel @Aparajit_Pratap @smangarole FYI.


I used PolyCurve.ByJoinedCurves and was nothing special.

@josef.radi does the node have two inputs or one?


@josef.radi Can you please tell us your Revit version? And your Dynamo 2.0.1 install steps?
Did you use the green cloud or download from dynamobuilds.com and dynamobim.org?

My Revit Version: 2017.2
Installed by dynamobim.org
For the install steps: We just downloaded from dynamobim.org and installed. no deinstallation from the old ones. For the Pre-versions this was no problem-I have more version installed:
Everytime open revit and open dynamo first time this appeares:
But that was no problem before. I just could joose which version I take.

@josef.radi in addition to removing dynamo packages - would it be possible to also remove all third party revit addins except for dynamo temporarily, and restart revit and dynamo and check these geometry selection nodes again?

@josef.radi we are unable to reproduce this on our end. Please try what @Michael_Kirschner2 suggested. But, if that doesn’t work we suggest the following:

So, could this be same reason I have missing nodes and broken wires?

I uninstalled and deleted all the Dynamo registry entries.

No joy.
Reinstalled Dynamo and still broken…Version numbers are still different.

1 Like

These are the right versions - I don’t think your issue has to do with this one. But I would advise a similar steps - remove all dynamo packages and add-ins temporarily, and see if you can reproduce.

Also look in the notifications menu item in dynamo’s menu for any notifications about incompatible addins.

I removed all dynamo packages and tried out - no change.
With removeing “third party revit addins” I think you mean this one:

I installed this Addin and the Dynamo Version 2.0.1 both yesterday…
Then this nodes didnt work anymore.

If it doesnt work after Addin remove I will reinstall the whole Dynamo and then I let you know.

Thank you!

I deinstalled Dynamo and installed again and now its working!
@Michael_Kirschner2, @Racel

Thank you!

not work

1 Like

digging this up again how do i uninstall dynamo core as it seems i have to edit the registry?

I had to uninstall Revit 2016 and keep 2017-2019 (not ideal) and this allowed me to have a working dynamo. unfortunately it took hours to run through the registry to clean up. Now the new issue none of the core nodes will save. Only the custom nodes will save but the core nodes will not.

Dynamo Core
Dynamo Revit

File from downloads page

do you have pyrevit installed? (if so try updating to latest version)

Thank you, that worked for 2017-2018, but not 2019. In 2019 the menu is blank, but I can do a right click search.