Dynamo nodes not working


#1

After I upgraded to 7.3, most Dynamo nodes are not working. The error says “Warning:No function called [insert node name] could be found. Please check the name of the function.”

I have tried uninstalling, and reinstalling the latest daily build, but am still getting same result. My current install is 0.7.4.3166

A screen capture of the error is attached.

What can I do to get Dynamo working again?

Thanks.

Dynamo Error01


#2

I don’t have an answer, but I am having a similar issue.11-13-2014 4-27-45 PM

 


#3

Hey guys, these are two different issues (I think)

 

post 1) have you installed Revit 2015 in the programsFiles folder or a custom location? - simple solution is to move it to ProgramFiles/Autodesk if you have installed Revit somewhere else.

 

post 2) are you running sandbox? You can’t use Revit nodes from the sandbox so they show up as unresolved.


#4

Sorry…I didn’t mean to hijack this thread. I just thought it was a related issue because after I updated, I couldn’t find a lot of the selection nodes and I had these warnings. My guess (I’m away from my desk) is that the nodes hadn’t been updated to the new version AND I had started Dynamo outside of Revit (if that’s what “Sandbox” means) instead of from the Addin tab. Please feel free to remove my replies. Thanks for the help.


#5

Hello Aseem Deshpande,

You need to add Element.Geometry after Select Model Element and pass output to Curve.PointAtDistance.

Select Model Element will return Model Curve and we need to extract Curve from that before passing that for any other Curve operations. (see attached image)

 

Hello Rob Kuffel,

When you run Dynamo outside of Revit, that is called StandAlone Dynamo.

On StandAlone Dynamo all Revit Nodes will shown as Yellow in color with Deprecated tag on them.

If you look at library, you will notice there is no Revit category.

Hope these answers will help.

Thanks,

Ritesh

Select Model Element


#6

Hello <span class=“author-link”><span style=“color: #428bca; font-size: small;”>Michael Kirschner</span></span>,

Actually I have exactly the same problem that <span class=“author-link”><span style=“color: #428bca; font-size: small;”>Aseem Deshpande</span></span> has been encountered.

I am also recieving the error saying: “Warning: No function called %get_Point could be found. Please check the name of the function”

in his response you had mentioned the Revit has to be installed in program file/ Autodesk folder. It is the same directory that I have installed Revit, however, I still have this problem.

Just for rechecking, I installed Revit/ Dynamo both on my PC and also my laptop. And on both I am recieving the same error although the path is correct.

Would you please give me some advice what other issues could cause the error?

Thank you so much

fereshteh