Dynamo Revit geometry nodes not working in 2019 only

For the last month any node that relates to Revit Geometry has been malfunctioning in Revit 2019 (19.2). Revit 2018 & 2020 are fine. Any node that doesn’t relate to Revit geometry also works fine in Revit 2019.

This issue also occurs when Revit 2020 hasn’t been installed

A simple OOTB point coordinate node returns the error:

Warning: Point.ByCoordinates operation failed.
The type initializer for ‘Autodesk.LibG.LibGPINVOKE’ threw an exception

In Revit 2019 only

The Dynamo version I have installed is:



I have tried uninstalling and reinstalling Dynamo Revit (but I have not tried to clean it from the registry)

The Revit Addins I have loaded are

Yeah, I have had this issue for a while for Dynamo 2.X, I re-installed dynamo with a different build version, downloaded from https://dynamobuilds.com/

I went back to 2.0.1.

DynamoCore 2.1 and DynamoRevit 2.1 only support 2020.
2.0.1 - 2.0.3 will run on 2017 - 2019.

1 Like

Thanks Michael,

I’m still curious as to why my Revit 2018 still works

Do I have to clean the registry? I tried just rolling back just Dynamo Revit but it didn’t work

make sure you uninstall dynamo core and dynamo revit 2.1 - you might need to do the registry clean to allow the 2.0.x installer to fully install.

Removing Both Dynamo Revit and Dynamo Core worked once I installed 2.03, 2.01 didn’t work (no changes to the registry were required)

Thank you

from this info, sounds like you are using 2019.2 - we added support for 2019.2 in 2.0.2. Glad you got it working.