Dynamo solid too complex for Revit

Hello All!

I’ve created a solid in dynamo from Sufrace.ByLoft. From here on I’m able to create a solid from this undulating surface. All seems right because I get a volume out of this surface.

All the previous is based on another topic:


However, when I try to import this solid into Revit, It imports only surfaces. Those surfaces represent ‘2 sides’ of the solid. Am I doing something wrong, or is my geometry to complex?

Since I’m a new user, I can’t put another image in this post…

The imported solid in Revit:

The solid in Dynamo:

Springs.FamilyInstance.ByGeometry seems to be throwing a error
An inefficient trial and error suggestion would be to make small alterations to the geometry and try.

You could also try ImportInstance.ByGeometry and FamilyType.ByGeometry

Hi Vikram,

Thanks for your reply!

I’ve tried ImportInstance.ByGeometry but I get the same result. I’ve also tried exporting it as Sat. Doesn’t work either.

I doubt if Springs.FamilyInstance.ByGeometry is creating the error.
I suspect the problem lies somewhere else, because my ‘ghost geometry’ in Revit doesn’t match my dynamo geometry…

Try altering the Revit units and see what happens (again, just guessing)
Might help if you upload the relevant files here (or provide a dropbox link to the same, if you can’t)

1 Like

Herewith the script en the revit file I’m using. I’ll try altering the units.

Revit file.rfa (348 KB)
CAD Geometry Wegdek.dyn (16.6 KB)

I’ve tried altering the Revit units, but I get the same result. Only 2 faces of the solid are imported.

Try this node from spring nodes





Hi @jeroen.infranea

Can you show preview here

Not the 3d preview watch preview.

You mean like this?

Yes! And now try this changes:

I’ve tried this node, unfortunately gives me the same result. Thanks!

Same result as before

Add “List.Create” node after “Solid.ByJoinedSurfaces” node.

1 Like

Yes sir! Still the same result…

It works fine from my end. I have tested your files :slight_smile:. Could you uninstall and reinstall again springs package.

@jeroen.infranea I have also tested using OOTB node it works fine. Which Revit Language do you use?