Springs Family Instance By Geomeotrry


When converting dynamo solid to Revit, everything seems ok from what the nodes say and is in correct spot in project, but the solid in revit is unselectable, and transparent.
Only way to delete is through undo or delete from project browser.
Same result for the familytype.by geometry node.

But when I do it another computer, with a lot less custom nodes installed, it works fine.

Any reason why it solid is unusable in the other computer? Anyone had same problem?
Are there packages conflicting with the springs nodes?

And this is dynamo 1.3.4 tested in revit 2019

Hi @AB01

Could you please drop here revit file?

1 Like

Just wanted to weigh in and say I’ve noticed the same behaviour for large geometry imports using this node. I’ve been using Dynamo 2.0.3 so I don’t think it’s a 1.3.4 issue. You’re not alone on this one :slight_smile:

Typically I will either close my session, or select the instance from project browser and place a new one, which typically then shows up.

I’m guessing it might have something to do with the ability for Revit to show something it’s just created via this specific API transaction - just guessing though.

Unable to send revit file because its for work.

But i did test it again on the same computer that had issues and the same project. This time deleted all packages except for the packages i required. still same error. Strange thing is in some views it is fine

Tried it on same computer but brand new project. it did work fine.

GavC - creating new instnace never worked for me. never tried closing session.

Looks like its a Revit model specific error, but cant think of a “setting” that fixes it.