Dynamo Sandbox geometry nodes stopped working

I have been successfully compiling and using Dynamo Sandbox for a while now, while Dynamo was checking out the license from Autodesk Alias on my machine for the geometry nodes (I think). Around a certain commit date however, Dynamo started to fail finding the LibG binaries needed to run any geometry node.

I suspect commit fe807ad6 to have introduced the “problem” for me, but I might be wrong.

Dynamo version that still works for me is 2.8.0.1943 according to splash screen. Any version after that fails to find the needed licenses and throws errors on the geometry nodes like Circle.ByPlaneRadius etc etc.

Am I doing something wrong on my end?

Perhaps it is looking for a newer geometry library (ie: 2.9 wants LibG version n+1 but you may only have LibG version n+0).

What version of Alias do you have installed?

1 Like

Sounds reasonable. I’m using AliasSurface 2021 Update 1 here, afaik the most recent version currently.

I’m returning to this topic because I still cannot get any of the Sandbox versions (downloaded or self-compiled) to work with the Alias license somehow. Currently on Alias 2022.1, that version comes with the latest libg 227 version:

They also do work fine when I launch Dynamo from within Alias. But running Dynamo Sandbox, they just don’t get picked up ever:

The Dynamo version shipped with Alias is Dynamo 2.11.2.5455
Is there a step I’m missing?

try the -gp flag presented in this thread:

you can use it to point to the autodesk geometry libraries when starting sandbox.

2 Likes

Thanks for your input @Michael_Kirschner2 - this indeed did the trick! For Alias, the folder that had to be used was C:\Program Files\Autodesk\AliasSurface2022.1\Dynamo\Dynamo Core\2\ASM

When creating a link with this flag as described the libraries are found and used, awesome!

1 Like

Hello! I´m like really new into this and the first thing that pops up is this same error. Please help.

I´m trying to use simple geometry to learn and follow the steps just like the tutorial videos.

This is how it looks running Dynamo built in Revit 2021 but…


This is how it looks like while i run Dynamo Sandbox.

I’ll appreciate any help because I can’t go on with this unsolved.

Thank you!

I’m going to show another example:


Have anyone fixed this or have found a way to do it?

@charliesantillan did you try what Mike suggested here? :slight_smile:

Well thanks! It’s changed at least the sign:


But still gettin an error.
I don’t know what else could it be.

Not sure if this is it, but… if you have Revit 2022 installed but not Revit 2022, then the Geometry library that Dyanmo 2.13 is looking for won’t likely exist on the system as it uses a newer version; So while it might load a geometry library, it won’t necessarily work the same way.

Try installing Dynamo Sandbox 2.12 and see if that works - if so my hypothosis is confirmed and you can try installing Revit 2023 to see if that works for Dyanmo Sandbox 2.13.

1 Like

can confirm what @JacobSmall has just posted, it is a matter of pairing a DynamoSandbox version which calls a matching libg.dll from the Autodesk product you’re using it with. In case of Alias, this has been upgraded between 2022 and 2023 for instance.

The error you’re currently getting indicated that libg.dll is indeed found, but the call to the invoke function in the Point class fails. As a starting point, you can initiate Dynamo from within your Autodesk app, and check its version number. Pick a matching DynamoSandbox version, use the gp flag, and it should work. From there, you can test with higher DynamoSandbox version numbers until it starts failing. With each update to your Autodesk product you can try if newer DynamoSandbox versions work.

2 Likes