Dynamo Sandbox Error

Can I still ask a topic about Dynamo Sandbox? I am trying to make Dynamo Sandbox work with geometry by following the steps shown in this thread below,

but I get errors. I really need to continue studying dynamo outside of revit.

A partial screenshot of the error is shown below:


Thanks in advance.

Which Autodesk product(s) do you have installed?

hi @john_pierson ,

I have Revit 2020 installed in my machine.

Do I need to open the Revit Software while using Dynamo Sandbox?

Thank you ^^

Hmm. That is odd. With you having Revit installed that shouldn’t be an issue. I wonder if ASM is an older version and that’s throwing something off it sandbox? Thoughts @solamour @Michael_Kirschner2

You need to use a version of sandbox which uses a matching version of the geometry library - use the same version that is in the DynamoRevit about box.


hi bro @Michael_Kirschner2 ,

Thank you very much… with your solution Dynamo was able to avoid node error.

But the I am facing one more problem, and that is the 3D preview of the script is not showing… Even the 3D grid and Planes are not showing in the DynamoSandbox.

I tinkered with the background preview settings but I think there is no problem with it.

if you are using sandbox < v2.7, try installing directx 10.

hi bro @Michael_Kirschner2 ,

I am current using sandbox 2.3.x.x, and my system has directX 12 installed. I will try to check if there is a way to go around it. I will update if I ran out of ideas ^^…

the post below solved the background problem ^^ thank you very much guys ^^

1 Like