Dynamo Core 2.1-2.3 sandbox can't resolve nodes

tried to install Dynamo Core Runtime V2.1 and 2.3 but I always get error messages

Tried to copy the missing files from libg… folders in the root directory of sandbox.exe. Then files are found til I get the error:

The type initializer for ‘Autodesk.LibG.LibGPINVOKE’ threw an exception.

From here I don’t know further…

This happens to every file I open in sandbox on this machine.

I already deleted previous Dynamo Studio versions. Please advice how this sandbox solution should work!


Do you have a version of other Autodesk core products (AutoCAD, Revit, Alias, etc) installed as well?

Thanks for replying,
yes indeed, Alias, MAX, MAYA.

Have DynamoAlias V2.0 installed on another machine and there it works fine.

Also Dynamo studio 2017 worked fine with other ADSk Apps.

Is this an issue?

right now you’ll need Revit or Civil3d installed, sandbox only looks for those currently, it could look for others though - will look into this.

Dear Michael,
before spending hours again on installing, testing and clean up of diffrent versions of sandbox , is there any update to this topic. Is it possible to run with other ADSK software installed and without revit or civil3D?

Appreciate your feedback

no, this is still limited to these products - we have this tracked in the backlog though.