Dynamo Player for Revit not showing correctly

Hi There,

I have Revit 2018.2 installed as well as Dynamo 1.3.2 on my PC,

When I click on the Dynamo Player button it becomes grey but the player doesn’t pop up,

Following some investigation I found that the player software does launch as it is visible within the task manager under “Processes” and “Details” and when I close the Dynamo Player from within the Task manager by right clicking and selecting “End Task” the Dynamo Player button within Revit returns to before it was clicked,

I can then click on the Dynamo Player button again but to alas it still does not show up,

Any idea how I could solve this issue?

I have uninstalled and reinstalled Dynamo, tried running the Dynamo Player as an administrator from outside Revit but none of these options seemed to solve the issue,

Regards,

Kayle

Hi Kayle,

I’m facing the same problem with my dynamo player, did you find a solution?

Regards,
Eric

Yes,

I also have the same issue. Try to search all our forum and other, but still no solution.

Could any one save my poor life?

Thanks a lot,

@daotangluc @Ericroche @kayle.whitehead

1 Like

@salvatoredragotta
Follow exactly which you suggested, but still not working.

Please get me out the hell! :(((

Thanks,

01

@daotangluc Did you clean the registry?

1 Like

I found a solution: I changed the permissions on my temp folder to Full control.
C:\Users"your user name"\AppData\Local\Temp

2 Likes

@salvatoredragotta
Clean registry with Wise Registry Clean - still not work
@Ericroche:
Done - but have no change

:frowning:

I’m having the same issue here. Essentially can’t use the Player with Dynamo 2.0.1 and 2017 or 2018. I think part of it is the fact that when you run Dynamo, you get asked what version to use, but with Player, it is not clear what version it uses by default. If you run player, and then Dynamo, in my case it says 1.3. So, it is very annoying and frustrating. Hopefully there’s a fix soon. I’ve tried above suggestions with no luck.

I had this problem a while ago. Tried to get a solution through the autodesk ep support but did not help.

I’ve found an solution that Works for me. Dynamo Player grays out after assigning an directory folder.

You can get the Player working again after deleting the following file “dynamoplayerinstance 1”. Its located here: C:\Users\USERID\AppData\Local\dynamoplayer\User data

Use your own user id.

To keep it working, copy your dynamo files in the default “sample” directory (instead of assigning an folder again) and refresh.

Let me know if It Works!

2 Likes

I just ran across this problem and @Thomasbsmits solution worked great! Thanks!

1 Like

Thanks, your solution worked for me. That’s great!
But the question to Autodesk, when you will fix it.
I we have a firm library of dynamo definitions on our server. I want users to link to the server folder and use dynamo definitions I’ve made for them. With this link broken, it is becoming so cumbersome to copy *.dyn files from server to local.

@Bzz FYI.

so are you saying to change the user data folder name to my userid?