Dynamo packages/nodes not loading after reinstallation

Hi All,

Yesterday I was trying to use the Clockwork node FamilyType.ByPointAndView and was having trouble getting it to work so was reading previous forum threads on the issue. I had gotten it to work once but afterwards it was no longer working and I couldn’t figure out the issue. Anyway, I found this thread where someone was suggested to uninstall all of their packages, restart Revit/Dynamo, then only reinstall the Clockwork package. This suggestion worked for the user so I figured I would try it as well.

http://dynamobim.org/forums/topic/placing-a-detail-component-in-revit/

Well, the FamilyType.ByPointAndView node still would not work for me, but I’ve moved past developing what I was hoping to use that with; what my issue is now is that I am missing a handful of nodes that I use frequently. I reinstalled all of the packages I had installed previous to uninstallation, and still am missing the nodes. I’m not sure the scope of what is missing but all of the nodes that begin with “ElementFilter.ByParameterValue_____” are gone (i.e. Parmater value contains, equals, does not contain, etc.). I can’t identify what package these nodes are included in via Google/forum searching, and I am certain that I have installed all of the same packages I had installed previously (compared to a screenshot of my folder before uninstallation).

To try and remedy this I uninstalled all of my packages again, uninstalled Dynamo, reinstalled Dynamo, reinstalled all of my packages… and still am missing these and unsure of what others. I will note that Dynamo is correctly pathed to the location of my package/nodes.

I thought reinstallation of Dynamo and all the packages would have worked, but I still have this issue. I would appreciate any ideas on how to fix this, as my general workflow when using the program is being slowed significantly without the nodes I am missing!

Thank you in advance!

…and you have installed the Clockwork version that fits with your dynamo version?
if you have “Dynamo 1.3.1” then you have “Clockwork for Dynamo 1.x”!

if you go to this folder “%appdata%\dynamo” you can find your loaded packages and just delete the folder containing the package you want to “uninstall”… and then re-install.

erfajo, thanks for the quick reply.

Yes, I have installed the correct Clockwork version. The Clockwork nodes are all available when I open Dynamo. (The FamilyInstance.ByPointAndView still not working isn’t the problem I’m trying to figure out at the moment… though would like to in the future.)

The issue is despite uninstallation and reinstallation of both Dynamo and all packages I had been using, there are a handful of nodes that are missing. I had initially handled uninstallation of the packages by deleting the packages from the “%appdata%\dynamo” folder.

It’s possible this isn’t an installation problem and I just can’t figure out what package I haven’t reinstalled. To my recollection they appeared to be preloaded in Dynamo, but I could be wrong. Are you able to identify for me what package the “ElementFilter.ByParameterValue_______” nodes belong to?

1 Like

try Beaker

1 Like

by the way… I cant find the node “FamilyType.ByPointAndView”, and I have Clockwork installed.

It was Beaker that I was missing!! Silly… I had literally reinstalled packages in order of a screenshot I’d taken of my package folder before uninstallation. Maybe the Beaker package folder was accidentally inside another folder.

Do you by chance also have the Bakery package installed? When I reinstalled all of my missing packages, I had to uninstall Clockwork to install Bakery because it is a dependency. When I installed Bakery, I noticed it installed Clockwork for Dynamo 0.7x and the FamilyType.ByPointAndView node was no longer available, so I reinstalled Clockwork 1.x and it became available again.

Bakery package is a nightmare, it includes packages that the editor is not in charge for… therefore installing that package is so troublesome that I have removed it.

Most likely can you find comparative node elsewhere.

I have found Bakery to be problematic at some times and have been debating whether or not to uninstall it, considering I have found equivalent nodes in other packages for any of the Bakery nodes I do use. The majority of the Bakery nodes do not have use for me and many of them lack descriptions as to what they actually do or what inputs they are expecting.

Will you mind explaining to me what “packages that the editor is not in charge for” means? I will most likely be uninstalling the package.

Dependencies. Bakery has quite a few. I recommend installing that one manually. Download from dynamopackages.com unzip into directory,

I cant remember it anymore, but Clockwork is one of them and also Archilab…

my favorites is Rhythm, Archilab, Springs, Clockwork, Lunchbox… but also more specialized packages like MEPover and many more. Backery is not one of them :slight_smile:

as we speak has @john_pierson entered the post… the father to Rhythm and formerly Beaker :wink:

1 Like

Ah I understand! Yes, I had installed Bakery manually the first time I installed it to avoid the dependency uninstall/reinstall issues. I’ve just decided to uninstall it entirely because I’m realizing now it keeps causing Dynamo to load Clockwork 0.7x rather than 1.x if I reopen Dynamo.

My packages are all up and back to working now :slightly_smiling_face: (well, not including that Clockwork FamilyInstance.ByPointInView node, but that is a separate issue from this post :roll_eyes:)

Thank you @erfajo for helping my identify the package I was missing! Your favorite packages are my favorites as well and I would add SteamNodes and Beaker for that list!

Thanks so much @john_pierson for the awesome packages :smile: The main reason that led me to make this post was because I was searching for those Beaker nodes (and didn’t realize that was the package I was missing! :sweat_smile:) The ElementFilter.ByParameter____ nodes are probably my most used nodes!

2 Likes

Through this community, I’ve learned to know a lot of skilled coders. Many of them is in the “regular” group and those who are very active in general. However, do not mistake, some of the best is “hiding” themselves as basic members :wink:

1 Like