Clockwork package keeps uninstalling

Hi all,

I have an issue with the Clockwork 1.x (1.0.3) package. I’m pretty sure it started when i Installed the Bakery package.

I’m using dynamo version

From the beginning… I uninstalled all of the custom packages within dynamo so I could install the ‘Bakery’ package. All was going well until I went to install the ‘Landform’ package. An error came up saying that Clockwork had already been installed, this is because it was a dependent of the Bakery package I imagine.

So the clockwork package was removed and the landform package installed along with clockwork.

Everything was working fine until I restarted revit and none of the clockwork nodes would work.

Now I have to reinstall clockwork every time I open revit.

I’ve tried several combinations of installing the packages below:

But no luck.

Does anyone have any suggestions?

Thanks for reading,


Interesting since it happened to me also.
Same Dynamo version and smae package version.
I was using a custom folder, i’m testitng the default and it seems to ne sticking now.

It’s a pain isn’t it! I’ve got a custom folder for custom nodes but all of the downloaded packages are in the default location. (The top path in the package paths is the default one).

I’ll try removing the custom folder and see if that changes anything.



I dont use the package manager anymore for this reason.
I download my packages from the Dynamo Packages website , unzip them and copy the folders to my network path (eg R:\Dynamo Packages\1.3)
Set the path in Dynamo, restart Dynamo.


Hi Marcel,

Thanks for the tip, looks like i might have to do this. The package manager is handy though!

I have had a similar issue previously and you need to locate the dynamo settings file which you can find by following the below information.

Close Dynamo/Revit

Type the following location in explorer(assuming you using dynamo from revit):
%AppData%\Dynamo\Dynamo Revit

Go to the version you have installed then you will see “DynamoSettings.xml” open it within notepad.

Find this:

    <string>FOLDER TO UNINSTAL</string>

Replace the above with the following:
<PackageDirectoriesToUninstall />

Save and close. Then reload revit/dynamo and re-download the package you want from package manager or you can manually do as indicated above by @Marcel_Rijsmus. Then when you reload dynamo it should not install the package anymore

Thanks Brendan,

Will this stop all future packages from being uninstalled or just the one I am referring to? I would like the package manager to be able to uninstall packages when needed that’s all.


When you next tell the package manager it should still uninstall the package but hopefully not leave this setting in the setting file.