Dynamo not running/working

Hi everyone,

I’m trying to run some scripts that where working yesterday and nothing is happening. No error but also no output. Even the most stupid things are not being runned.

From yesterday to today I have not downloaded/erased any package nor upgrade the dynamo or revit version.

Has anyone experienced the same for knowing where can the problem come from?


What’s written near the Run button ?

Have you tried pressing Escape while being in Revit ? Sometimes, when you are modifying an element in Revit, Dynamo won’t be able to run.

It says Run Completed, as if everything was ok.

Yeah, I’ve checked the Revit, and even closed and opened everything a couple of times :disappointed_relieved:

Have you tried in another Revit Project ? Or another Dynamo script ? (Just taking guesses here, never happened to me)

(Also, quite obvious, but you clicked on Run right ? :stuck_out_tongue: )

Haha, yes, I clicked on Run, and tried it on different Revits.

I will try coping everything into a new Dynamo file

Ok, after coping the nodes to a new files is at least doing something but it is not capable of finding the files in the path given(which is correct because I have checked it), and it says that the file is not existing, although it is not true because the files is there. Has anyone had this problem before?

Have you tried restarting your computer?


And tried another file placed on e.g. Your desktop?

Yes, nothing worked.

I will try it again tomorrow…

Can you send tbe log files associated with that session? Your IT department may have locked you down somehow.

what do u mean for log files?

Can’t recall the exact directory, but it has a similar path to your default packages folder. Go to your manage node and package paths folder, find what the directory is, and check two levels up from there.

Ok, I’m still not sure about the files u are asking me for… the packages are found in here:
C:\Users%user%\AppData\Roaming\Dynamo\Dynamo Revit\2.0\packages

C:\Users%user%\AppData\Roaming\Dynamo\Dynamo Revit\2.0\Logs

1 Like

Ok, there are lots of files from today, which one I know is the one?

The one corresponding to the not working Dynamo instance i guess.

1 Like

Here is the last one

dynamoLog_67a08712-b128-4a0b-b0c5-f7d337c45a6c.txt (4.8 KB)

Nothing showing in the log - try saving the file to a new location and see if that works. if not, can you upload your .dyn here so I can have a look at that?

Here you are,

I already tried changing locations

Longitudinal_Drainage.dyn (130.1 KB)