Dynamo not responding to simple text nodes

Hello, I have this weird error where dynamo does not want to process any nodes at all when I have something selected. In this case, i only have 6 families selected and am simply trying to pass the word “hello” into a watch node. But even that proves to be too difficult for dynamo to do at the moment. I tried restarting dynamo many times and even restarted revit with the same results. Anybody have any idea what is going on? Thanks!

Looks like a case of ‘waiting on Revit input’. Try restarting your CPU, and if that doesn’t work restart Revit, open a new file, start dynamo and create a new graph, place a string and a watch node as you did here, and confirm the bug reproduces. If so than force quit Revit and upload your Dynamo log and your Revit journal to the forum.

@mix share rvt and dyn files, we’ll try to help

1 Like

Well I tried restarting both my vm and my laptop last night to no avail. It seems to happen when I simply have more than one family selected. At first, I thought it was “waiting on revit” too. but there is nothing for it to wait on. I am simply just selecting them. And in the lower right hand corner of revit, where there should be a command, it just says “Ready”. See below. So I started a new project from the revit default construction template and placed a few families and tried a new script with a just a string in it and it appears to be working. So I guess I cannot replicate the bug. But as soon as I “let go” of my selection in runs right away. Any other Ideas?


helloworld.dyn (1.3 KB)

Can you post the Revit journal and Dynamo log file from a clean session as requested?

The ‘when something is selected’ aspect has me thinking you have another add-in running which is preventing Dynamo execution.

You want the logs from the “clean” session meaning the one that worked? Not sure what that would tell you but here they are:
dynamoLog_f9eb42f6-3163-4bb5-9001-601176dce39a.txt (112.7 KB)
journal.0022.txt (251.2 KB)
I thought that might be the case too, but I dont think I have any addins running. I did just install Screencast though, would that do it?
Much appreciated!

I am seeing a lot of package and node failed to load errors, as well as some 6 load errors around core Dynamo components (ProtoCore, DynamoCore, DynamoServices, DynamoWPFCore). These appear to be related to having nodes build around 2.x loaded into a 1.x environment.

As a next step, rename your packages folder(s) so Dynamo won’t see them on restart. Then try opening your troublesome graph. There may be issues with it preventing full execution as a result of the missing packages, but if it runs the text example you’ll know where the issue is, and you can start adding packages back until you ID the cause.

Ok Ill try that, but I have been working with these “errors” for a long time now. Not sure why they would start acting up on me now. But it cant hurt to try it.

Still no dice. It wont run even after I renamed all my package folders:


Please advise.

Can you post that dynamo log?

If some things selected in Revit Dynamo will until the the clear the Revit section.

Do not selected anything in Revit while Dynamo running.

Sure thing! here you go: dynamoLog_33390358-b3cb-4869-8671-34ec5dff582f.txt (3.9 KB)

Well, nothing there… can you grab the Revir journal from that time as well? Grasping at straws here as nothing is showing as anything other than healthy in the log…

Ok, well if you can help that would be good. I cant use Dynamo at all like this. Here is the file you requested. Please advise.
journal.0022.txt (251.2 KB)

6 minute span of time between 7:15 and 7:21 with no errors showing… it does show Revit interactions with the mouse starting RIGHT AFTER you opened the graph (opened hello world in Dynamo at 7:16:50, and Revit starts tracking mouse movements and interactions at 7:16:52) which makes me thing you’re being pushed back into Revit, perhaps due to an info sec issue of some sort. Did you try to run the graph in those two seconds?

If you have Dynamo 2.0 installed it’d be good to see if the behavior is the same there.

Also, are you physically on the system or is this a remote desktop or virtual machine of some sort?

If the behavior is the same in Dynamo 2, and you’re not on a virtual machine I recommend starting a ticket with Autodesk support as this will take remote troubleshooting from what I can see.