Dynamo is not working!


sorry for the dramatic title, but i have a wired problem whenever i load a dynamo script, it doesnt work, it gives :

as you can even reading levels gives null!

also when i open a script, the nodes appear on top of each other like this:

don’t know if both problems are correlated, but they appeared together

Likely a conflicting Revit add-in. Make sure Revit and all the add-ins you have installed are up to date, and if he issue persists try removing all add-ins and see if the issue persists.

1 Like

Thank you for your reply, i tried removing all add-ins (i didn’t have anything installed besides py-revit and BIM interoperability, i removed both but the problem persisted.

its worth to note that some scripts work fine and some don’t, and if the script doesnt work and i want to add a code block for example, i get it like this :


i cant write anything there!

Post your Dynamo log and Revit journal and I’ll take a look on Monday when I get a chance. You can also read those for what dll and associated add-ins or tools may be at fault.

1 Like

Would like to report that i have fixed the problem by uninstalling all of the dynamo packages and redownloaded them.

In any case, thank you Jacob

Something restarting the PC Will resolve this kind of issues.

It is also solved by creating a new file and copying what you already had advanced, of course if you did not want to uninstall and install again

i tried that, didnt work!
maybe when i paste the outdated node, it causes it to stop working

tried that not working also …

If it was resolved by removing packages, than a package than you may have had a version conflict due to reuse of old packages. Try reinstalling with the correct package version for you Dynamo/Revit build.