Dynamo not launching in revit 2020 manage tab, just a white box appear

Hi ,
Need advise.
I am unable to open Dynamo in the manage tab of revit 2020.
Was able to open it a few days ago.

Followed a solution posting dated Nov 2019.
Tried uninstall & reinstall again, same issue still arise.

Dynamo & revit logs below…

Dynamo log started 2021-06-02 05:30:13Z
2021-06-02 05:30:13Z : Python template set to default.
2021-06-02 05:30:13Z : Dynamo – Build 2.3.1.11775
2021-06-02 05:30:13Z : Duplicate migration type registered for SunPathDirection
2021-06-02 05:30:15Z : Dynamo will use the package manager server at : https://www.dynamopackages.com
2021-06-02 05:30:15Z : DynamoPackageManager (id: FCABC211-D56B-4109-AF18-F434DFE48139) extension is added
2021-06-02 05:30:15Z : Backup files timer is started with an interval of 60000 milliseconds
2021-06-02 05:30:15Z : SYSTEM:Environment Path:C:\Program Files\Autodesk\Revit 2020\AddIns\SteelConnections;C:\Program Files\Autodesk\Revit 2020\en-US;C:\Program Files\Autodesk\Revit 2020;C:\Program Files (x86)\Common Files\Intel\Shared Libraries\redist\intel64_win\compiler;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\WINDOWS\System32\OpenSSH;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon;C:\Program Files\Common Files\Autodesk Shared;c:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;c:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Microsoft SQL Server\120\Tools\Binn;C:\Program Files (x86)\PDFtk\bin;C:\Program Files\Common Files\Autodesk Shared\Advance;C:\Users\byeow\AppData\Local\Microsoft\WindowsApps;C:\Program Files\Common Files\Autodesk Shared\Advance;C:\Program Files (x86)\Common Files\Autodesk Shared\Advance;C:\Program Files\Autodesk\Revit 2020\AddIns\DynamoForRevit;C:\Program Files\Autodesk\Revit 2020\AddIns\DynamoForRevit
2021-06-02 05:30:15Z : RENDER : Rendering Tier: 2
2021-06-02 05:30:15Z : RENDER : Pixel Shader 3 Supported: True
2021-06-02 05:30:15Z : RENDER : Pixel Shader 4 Supported: False
2021-06-02 05:30:15Z : RENDER : Software Effect Rendering Supported: True
2021-06-02 05:30:15Z : RENDER : Maximum hardware texture size: 8192,8192
2021-06-02 05:30:15Z : RENDER : Rendering Tier: 2
2021-06-02 05:30:15Z : RENDER : Pixel Shader 3 Supported: True
2021-06-02 05:30:15Z : RENDER : Pixel Shader 4 Supported: False
2021-06-02 05:30:15Z : RENDER : Software Effect Rendering Supported: True
2021-06-02 05:30:15Z : RENDER : Maximum hardware texture size: 8192,8192
2021-06-02 05:30:15Z : DynamoManipulationExtension (id: 58B0496A-E3F8-43D9-86D2-94823D1D0F98) view extension is added
2021-06-02 05:30:15Z : LibraryUI (id: 85941358-5525-4FF4-8D61-6CA831F122AB) view extension is added
2021-06-02 05:30:15Z : NotificationsExtension (id: ef6cd025-514f-44cd-b6b1-69d9f5cce004) view extension is added
2021-06-02 05:30:15Z : PackageManagerViewExtension (id: 100f5ec3-fde7-4205-80a7-c968b3a5a27b) view extension is added
2021-06-02 05:30:15Z : Workspace Dependency ViewExtension (id: A6706BF5-11C2-458F-B7C8-B745A77EF7FD) view extension is added
2021-06-02 05:30:15Z : Welcome to Dynamo!
2021-06-02 05:30:15Z : 00:00:00.2406666 elapsed for loading Dynamo main window.
2021-06-02 05:30:15Z : Preparing to load the library resources.
2021-06-02 05:30:16Z : WPF Render Mode: SoftwareOnly
2021-06-02 05:31:15Z : Saving C:\Users\byeow\AppData\Roaming\Dynamo\Dynamo Revit\backup\backup.DYN …
2021-06-02 05:31:15Z : Backup file is saved: C:\Users\byeow\AppData\Roaming\Dynamo\Dynamo Revit\backup\backup.DYN
2021-06-02 05:32:16Z : Clearing workspace…
2021-06-02 05:32:16Z : Workspace Dependency ViewExtension: Object reference not set to an instance of an object.
2021-06-02 05:32:16Z : DynamoPackageManager (id: FCABC211-D56B-4109-AF18-F434DFE48139) extension is removed
2021-06-02 05:32:16Z : Goodbye

but cannot find any journals file here…
Revit Journals ( C:\Users\smallj\AppData\Local\Autodesk\Revit\Autodesk Revit 2020\Journals )

Greatly appreciate any help.

regards
Bryan

I managed to settled it already. thks.

@faithon126 How did you solve this , I am facing the same issue?

I solved something similar a while ago with this:
Hover over the blank Dynamo preview in the task bar > right-click > ‘Maximise’

Thanks, this worked for me.
Cheers!