Dynamo export excel fails

I am trying to run a very simple script to export one schedule to excel. But it is not working. Anyone can help me?

Hi @aafonsoBYKA8

What’s your Revit Version?

I think overWrite option causes that problem. It is a bug in Dynamo because it deletes the sheet and creates a new one. While that happens, it is shown an warning message…
Try to do it without overWrite and select a new path.

revit 2022.1

I just tried that and the operation fails.
It is very frustrating. I just need to find a way to export several schedules to excel… I really dont understand why this very simple thing isnt working.

What is shown if you click on “Read more”?

You can send file sample error to here ? I will review and edit it in open source. I have also seen quite a few questions about this.

@aafonsoBYKA8 Try using OpnXML export nodes. It’s available for Revit 2022.1:

1 Like

A couple of thoughts:

  1. you are writing a schedule to excel. It would probably be more simple to export as a text, and import the data into excel via the text file.

This offers a nice workflow as you can create a more dynamic link to the data and any post-processing operations in excel, even within the same sheet.

  1. there is an excellent add-in from bimONE for writing to excel, which also offers bidirectional exchanges. Doesn’t work well for type-based tables.

  2. regarding your error explicitly. Maybe you need to explicitly set the last Boolean to write as strings?

  3. Otherwise, you might try replace by condition using the ‚isnull‘ node to clean your data. I doubt this is the issue. I’ve sent ‚null‘ to excel many times…but perhaps if you are not formatting as strings, this is causing an error.

Thank you. I tried like that, but still not working

Now it only shows this

I cant upload files because I am a new member.
Here is a link to download the file.
Hope you can help me.


Check this:

This about importing. My issue is when exporting.

Do u have null data in your schedule, meaning empty cells? I have seen that cause this issue.

Try to export out a single item from the list where all 4 values exist and see if it fails.

Sched[0] from the image appears to have all values

Then try with one that doesn’t or doesn’t appear to anyway


Hi Teresa,

till we get a solution to your problem, you can use these-

let us know if it worked.

1 Like

I have no null values

Does it work if you use a single list item as I suggested?

The grouping headers are potentially causing the issue.


Thank you!
It exports like this.

Do you know how I can get it into diferent columns?