Dynamo Core Runtime 2.4 Not Running After Download

Hi @Michael_Kirschner2 thanks for the new suggestions.

I tried the first 3 following your directions, but no luck still not able to start Dynamo 2.4, and still nothing in the Dynamo logs.

I also downloaded and tried the 2 newest daily builds, 2.5.0 & 2.4.1, but neither of them would start either.

Damn. I´m sorry for you. Did you tried it on a second Computer. Did it worked there? Maybe old 7-zip?

I didn’t think about 7-ZIP being old.

So I tried the latest version (19.0) and same result. I also tried the alpha version that is available (19.0.2) it also lead to the same result, which was a blue wheel for a few seconds then nothing.

last thought for now - remove or hide formit - you can just rename the formit folder.

I just tried deleting FormIt and still no luck.

I really don’t want to do a complete format…but seems to be less and less options.

BTW I was able to download and run Dynamo 2.4 Sandbox first try on an old laptop I had at the office, so seems to be localized to my current workstation (laptop)

1 Like

Same here. Dynamo sandbox 2.4.0 not running after download. Dynamo 2.3.0 has no startup problems. Unblock zip, extract to desktop etc, nothing happens. W10x64 1809

1 Like

I am not sure yet, we are investigating, but I think it may have something to do with other products which use Dynamo like civil3d, Revit, Robot etc in conjunction.

You should be able to simply rename these folders to stop dynamo from being effected by these but that is just a guess at this point - I will post back here when we know something conclusive.

if you are able - knowing what adsk software you have installed will help track this down.

at the moment I think we have tracked this down to at least some interaction with Navisworks Manage - do either of you have that installed?

Yes I have Navisworks Manage 2018, 2019, and 2020.

okay, atleast that confirms whats going on - temp workaround I think you can just rename those folders.

I have the following Autodesk software installed, not including add-ins

ACAD 2018, 2019 & 2020
Navisworks Manage 2018, 2019 & 2020
Revit 2018, 2019 & 2020
FormIt Pro 17.4
Civil 3D 2020
BIM 360 Glue Client
Autodesk Desktop App
BIM 360 Desktop Connector
Dynamo Sandbox 2.3
Dynamo Revit 1.3.4 & 2.0.3
Dynamo Core 1.3.4 & 2.0.32019-09-27_7-45-35

1 Like

@CStorms we have a potential fix for this that is under review - when there is a sandbox build including it I will let you know.

in the meantime, it would be very helpful if you have time to rename navis manage 2020 to navis manage2020xxx and see if Dynamo starts.


renaming the Navisworks Manage 2020 to Navisworks Manage2020xx worked

Now currently I use Navisworks Manage more than I use Dynamo Sandbox 2.4, so I will need to change it back for now, but good to see it work!


I can confirm that renaming the NW Manage folder solves the problem of starting DynamoSandbox 2.4.0


starting DynamoSnadbox

Reading this I now want a Dynamo Snackbox :smiley: Bring on all the Dynamo-branded yum stuff!


thanks for helping to track this down and confirm the bug all.


@CStorms - please try the latest 2.5 or 2.4.1 daily builds, this should be fixed there.


Thanks @Michael_Kirschner2 I was able to get both 2.5 & 2.4.1 (current dailies) to work on the first try

2019-10-01_12-54-46 2019-10-01_12-52-59




I downloaded stable build 2.4.1 of DynamoCoreRuntime (Sandbox) this morning and it ran first time even with Navisworks Manage 2020 install.

Thanks, Dynamo Team for all your hard work on this case, and getting a fix out so quick!!

Case Closed! - Solution Download version 2.4.1 :slight_smile: