Dynamo Core Runtime 2.4 Not Running After Download


I have been trying to get the Dynamo Core 2.4 to work for the last couple of days with no luck.

I right-clicked and unblocked the Zip file, then I unzipped it using 7-Zip, but still no luck.

I also tried all the suggestions from this tread, but no luck.

I have Dynamo Core 1.3.4 & 2.0.3 installed
I have Dynamo Revit 1.3.4 & 2.0.3 installed
Revit 2018.3.3, 2019.2.2 installed

Revit 2020.1 with Dynamo Core 2.2.1 & Dynamo Revit 2.1.0

FormIt 17.4 with Dynamo FormIt 2.1.0

Civil 3D 2020 with Dynamo Civil 3D 2.1.0 installed

The only Revit Add-ins I have installed are the ones that come from the ADSK Desktop App.

I’m running Windows 10 with update 1903 installed if that matters.

All installed versions of Dynamo work, but I can’t get the 2.4 Sandbox to work?

Any suggestions would be greatly appreciated

I have Dynamo Core Runtime 2.3 installed, but uninstalled before trying to install 2.4. I have since reinstalled it and it also works fine?

Hi @CStorms

Have you tried uninstalling completely 2.0.3 including registries and then install 2.0.4 Core

Hi @Kulkul uluI, I had nto done that but I just tried what suggested and got the same result Sandbox 2.4 won’t start

Hi @CStorms - a few things to try

  • are you on the 2.4 stable core or a daily build?
  • find the 2.4 package folder and delete the packages which were migrated (if any)
  • what does your log file say in %appData% for the recent dynamo startups

what do you see exactly happen?

Hello @Michael_Kirschner2

I have the 2.4 Stable versions

there is no 2.4 Package folder, there are no 2.4 folders anywhere except for the downloaded one.

I can’t seem to find the log, where is it exactly?

Hello Carl! You can find the logs here - simply replace amours with your own thing.

To access this super easily, you can click in the File Explorer search field and type: %appdata%

Thanks @solamour I should have known that…need more coffee this morning.

As you can see there is no Dynamo Core 2.4 folder at all, so no logs to review


1 Like

this means Dynamo has not even gotten far enough to create the log folder, or failed to do so -
I would:

  1. remove packages from the 1.3 / 2.3 folder
  2. verify you unzipped with 7zip or unblocked the entire .zip before unzipping

when the core starts up it will try to migrate packages - there could be some issue in trying to copy these old packages for some reason that is causing a crash - you can just take all previous 1.3 - 2.3 folders out of this DynamoCore folder temporarily.

1 Like

As @Michael_Kirschner2 has indicated, i usually use point 2 when trying to open Dynamo sandbox after download, which is to unzip with 7zip then i do not have a issue where the exe wont load/open.


I have delete all Dynamo Revit and Dynamo core from my computer. I have also delete all dynamo packages from my computer

I downloaded Dynamo Runtime Core 2.4 stable versions from the website

I right-clicked on the zip file to unblock it, then I unzipped using 7-zip

Then I tried to run it by selecting the Dynamo exe file

Nothing happens, the little blue wheel spins for a second or less then it goes away and nothing happened?

which exe are you trying to open? There are a few in the folder, only DynamoSandbox.exe will show a UI.

Thanks for the Clarification @Michael_Kirschner2

I was using that exe

still no luck

you could try running as admin or moving the dynamo 2.4 folder to another location - like c:
were you also running dynamo core 2.3 from your downloads folder?
It’s possible the download is not complete - have you downloaded a fresh copy since trying the first time?
I just checked the 2.4 stable and of course it runs fine on my machine :frowning:

I just don’t know what it is with me and new builds of Dynamo :frowning:

I tried running as admin - No Luck
Tried moving the folder - No luck

Each time I reply I have downloaded a new version of the Stable build of Sandbox 2.4

I do have Civil 2020 and the Dynamo version of it installed? I was hoping not to have to uninstall that as it means a complete uninstall (and then reinstall) of C3D

Thanks for all the effort @Michael_Kirschner2 @Kulkul @solamour and @Brendan_Cassidy it is truly appreciated

P.S. I just tried the latest Daily Build of SandBox 2.5 and it also did NOT work, but 2.3 and older do work.

1 Like

Sorry you’re having so much trouble here - I hope in the future we can provide an easier experience - but for now, I think what might help is to record your screen - all steps you take from fresh download forward - you can send it to me directly if you don’t want to post it publicly.

1 Like

Yeah I’m sure its something on my end…seems to always be that way :thinking:

I will do a video and post it this weekend.


Good Morning @Michael_Kirschner2

Sorry I didn’t get to this on the weekend as I said, but you know how weekends can be.

I currently have no Dynamo or Dynamo packages anywhere on my system, also delete all registry files as per earlier link to the Dynamo Blog.

During the video I paused during the download, but it was a complete and full download.

As you can see in the video once I try to run Dynamo 2.4 I get the blue wheel for a few moments then nothing happens.

There is no sound in the video.

You can also see that no Dynamo Log was created after I tried to run the .exe file

okay, thanks for the video - a couple things to try

  • try downloading directly from dynamobuilds.com under the stable section
  • don’t both unblock before hand AND use 7zip (do either or) - I don’t know what interaction that might have… it likely does not matter, but let’s try to get remove any variations from our processes.
  • move the zip to the desktop before doing anything, and try running it from there - sometimes the downloads folder is extra restricted
  • if that all fails, try downloading and master build (2.5) to compare with.

We are going to make some improvements so that even if the dlls fail to load, we will still show a warning dialog with some hopefully useful log info.

one last thought, do you happen to have robot structural analysis installed?

No I don’t have Robot Structural Analysis installed.