Dynamo Core 2.3 Not Running

#1

I downloaded and installed Dynamo Core 2.3. I double-click DynamoSandbox.exe. A small window appears briefly regarding first-time run and migrating settings, then it disappears and nothing happens afterwards!

1 Like
DynamoSandbox not starting
#2

Anything showing in task manager?

#3

Nope. It just dies

#4

Try a restart, then see what items show up on the system when you go to start. Looking for any process which begin or any programs with a CPU spike.

FYI @Michael_Kirschner2

#5

DynamoSandbox shows up for a couple of seconds and dies.

#6

Since it’s a daily build, it might always be a bad one - you can try the next one or an older build - but I would also look at what package folders it might be trying to load / migrate - maybe try removing packages from 2.x core folders before starting it, and also remove any packages it migrated - potentially something causing a crash when it attempts to load them.

#7

I installed Windows 10 64 bit from scratch. Vanilla installation. I installed only Chrome. Then I downloaded and unzipped DynamoCoreRuntime v. 2.1.0… Same behaviour. So nothing to migrate, no previous packages or software. Nothing at all. The only way to solve it was to download 6.4GB of Revit that I don’t use.

#8

Hi @jabiw3SXRW I would like to get to the bottom of this if you have time to test and clean environments, so far I cannot reproduce that exact failure mode.

Did you get a chance to read through this:
https://github.com/DynamoDS/Dynamo/wiki/How-to-Utilize-Dynamo-Builds ?

@Qilong_Tang FYI

#9

I went through it and nothing in it strikes me as something I am missing. I am happy to schedule a live session today or tomorrow for you to view and control my laptop to see what the issue is. I have GoToMeeting that we can use.

#10

I would also be interested in the outcome of this, as I’m having the same issue. I tried 2.1 first, when I hit sandbox.exe nothing not even a pop-up. I tried the daily build from Apt. 5th, same thing, and I also tried the daily build from Aopr. 3rd still nothing.

I followed all the suggestion within this tread.

Now I do have FormIt Pro for Windows V 17 that has it’s own version of Dynamo 2.1 Sandbox, which works. Maybe you can’t have to versions?

#11

This does not sound like the same exact issue - in @jabiw3SXRW’s case sandbox opens and then closes/crashes soon after boot.

would you mind trying to unzip the .zip with 7zip?

1 Like
#12

The 7zip trick worked, before I just did the right click and extract.

Thanks for help!

#13

@Qilong_Tang FYI - seems the zip is still blocked on some users’s machines even though the binaries are signed…

1 Like
#14

This maybe a hint on impact of some recent changes on our CI machines. Let us bring this topic to the team and make sure it is addressed

3 Likes
#15

I have the same issue.

#16

Hi @adi please describe your issue in detail, there are two different issues described in this thread already.

#17

I have noticed this only recently that when you install dynamo and your system has Dynamo Revit but no Dynamo Core installed this seems to happen(see installed programs). EG you go to dynamo folder and run “DynamoSandbox.exe” but nothing opens/loads.

#18

Hi,
downloaded DynamoCoreRuntime2.1.0.zip > Extract All > Run DynamoSandbox.exe > nothing happens.
This is the first time I am trying to play with DynamoSandbox, so maybe I’m missing something.
I have Revit and Dynamo both open while I was trying to this.
Dynamo Core - 2.0.3.8104
Dynamo Revit - 2.0.3.8107
Revit 2015, 16, 17, 18 installed
Robot 2019 installed on the system.

#19

hmm, can you also try using 7zip to unzip the file? Please also shutdown the other dynamo - it should not effect sandbox but there could be something going on with CEFsharp - though this is unlikely.

The 7zip trick works if the dlls are blocked from being downloaded from the internet - this happens depending on your local permissions/security trust settings. Windows likes to block .dlls that come from “the internet” - our dlls are signed and in our tests this was not an issue, but it’s possible we missed some setup types.

#20

Unzipping using 7zip works. Thank you.