Dynamo add Spaces: Bottom doesn't touch floor


#1

I developed a graph that adds spaces in the MEP model from the linked Architectural Model.
The spaces on the first Level properly extend to the Room Boundaries as they should. But spaces added on the second level stop above the floor.

Anyone have any ideas for me as to just why?.. and what I can do to fix it.


#2

Is there an offset for the Space when you look at the properties in Revit?


#3

I don’t think so. I think I looked at that if I recall correctly. I believe all the spaces on 2nd level did this.

I added one manually and the same thing happened.

I’ll be in the office tomorrow and will look again.


#4

Do you have some room bounding floors hidden in some way? Or even from a link?


#5

Hi @mdhutchinson

That’s because you have ceilings in second level. To extend until room boundaries select ceilings and uncheck Rooom Bounding: