Dynamo 2.0.0 install causes problems with Python Scripts in both 1.3.2 & 2.0.0

Per @Michael_Kirschner2 request I started a new topic to track the issues with installing Dynamo 2.0.0 after 1.3.2 is installed and breaking Python Scripts in either version of Dynamo.

The original post is here, Dynamo and IronPython - incompatibilities with other applications

As additional test, I tried this on my virtual machine that I already had set up and tested in Revit 2018.2 and everything worked fine.

Additional here are some notes from my previous post tests. That machine did have Revit 2019 installed (the virtual machine did not), which installed Dynamo 1.3.3. Therefore after installing Revit 2019, I uninstalled Dynamo 1.3.3 and installed Dynamo 1.3.2 and then installed Dynamo 2.0.0. I also had Dynamo Studio 1.5 installed and found that in order to install Dynamo 1.3.2 after uninstalling 1.3.3 I had to uninstall Dynamo Studio. Then they dynamo installer for 1.3.2 worked fine.

@smangarole @Neal_Burnham more info here.

Hi @Nick.sipes - so I’m a bit confused the virtual machine did not have 2019 or studio on it and everything works fine there?

could you try using clrAddreference with the full path to the revitServices dll which should be in your DynamoRevit install folder instead of just the dll name - this was you know that you are attempting to the load the correct version of that dll. - and I mean to try this on the machine which is having the issue.

1 Like

@Michael_Kirschner2 in regards to your confusion of the virtual machine. Correct the Virtual machine did not have either 2019 or Studio and everything works fine. (one more reason I was very confused).

I’m in the process reinstalling Autodesk software as a result of my tests on the virtual machines appear to indicate that the issue was tied to something odd on this computer and possible tied to Autodesk software. I’ll post on update after the software is reinstalled. If that doesn’t solve the problem I’ll try the dll recommendation.

1 Like


I’ve reinstall the Autodesk Revit Software (2019 and 2018). Then uninstall Dynamo 1.3.3 (came with Revit 2019), and install 1.3.2 and 2.0.0 without any problems.

I have not installed Dynamo Studio yet, which may have been causing the problems. I was also able to install some windows 10 updates. I’m not sure what specifically fixed my issues, however both 1.3.2 and 2.0.0 are working as well as all python scripts.

Thank you for all of your help.

@Nick.sipes Thanks for the update. I am trying to reproduce this issue on a windows 10 VM (1.3.2 + 2.0). Can you please give me your original configuration when you encountered this issue?

Revit versions installed (please include point versions)

Dynamo Studio point versions (See the about box)

Also, were you able to install 1.3.2 without Revit 2016 or Revit 2017.0?

Sorry for yelling in the middle of the post. Did not know that hashtags translated to bold text with font increase.


the machine that is in question had Revit 2015 (latest update), Revit 2016 (update 7 for R2), Revit 2017.2.3, Revit 2018.3 (not 2018.3.1), and Revit 2019. It also had Dynamo Studio 2017.5 (might have been 2017.4).

in regards to windows 10, it did have fall creator updates and monthly updates December of last year.

Let me know if you have any other questions.

@Michael_Kirschner2, @smangarole

So I’m now having the same issue as I was having before with this computer. I know that I installed 1 add-in since Monday when I made my post that everything was working. I’m going to test if removing that add-in resolves the issue. I’ll follow-up with more information.

If you would like me to test anything let me know.


I am having issue with python in 2.0.0 too. On Revit 2017 once python node is placed on canvas and opend dynamo crashes immediately. (w7 64bit, python 2.7.13)

Hi @Vladimir_Ondejcik2 have you read this? Dynamo and IronPython - incompatibilities with other applications

if you are having a crash still after seeing if this applies please report on our GitHub issues.

@Michael_Kirschner2, @smangarole

Finally got around to uninstalling the add-in and now everything seems to be working fine. The add-in that was installed is called Spectrum BIM, I’m going to see if his new version causes the same problem.

Any idea why 2.0.0 would be causing this problem but 1.3.2 doesn’t have the same issue with the add-in?

Will help us to know what the add-in is, but my guess is that it’s a library conflict.